Solución de problemas del sensor de visión de IA con VEX V5

Si tiene problemas con su sensor de visión IA, consulte las secciones a continuación para identificar la causa y encontrar la solución adecuada para su problema específico.

Problema: el sensor de visión de IA no se conecta a VEXcode

Al configurar el sensor de visión de IA en VEXcode, la ventana no mostrará la vista del sensor de visión de IA y mostrará el mensaje "No hay sensor de visión de IA conectado".

Posibles causas

  1. El sensor de visión IA no está conectado correctamente a la computadora.
  2. Su navegador web o VEXcode no tiene permisos de cámara para acceder al sensor de visión de inteligencia artificial.
  3. El sensor de visión de inteligencia artificial no se conectará a VEXcode mientras Visual Studio Code esté abierto.

Soluciones

Solución para la posible causa 1

Si su sensor de visión de inteligencia artificial no está conectado correctamente a su computadora, verifique la conexión del cable a su computadora. Para obtener más información sobre cómo conectar su sensor de visión de inteligencia artificial a su computadora, consulte estos artículos para conectarse a Basado en la web y Basado en la aplicación VEXcode V5.

Solución para la posible causa 2

Si su navegador web o VEXcode no tiene permisos de cámara, el sensor de visión de inteligencia artificial no podrá conectarse.

Para solucionar este problema, consulte los siguientes artículos:

Basado en aplicaciones

Basado en la web

Solución para la posible causa 3

Cuando el sensor de visión de inteligencia artificial se conecta a una computadora con VS Code ya abierto, primero establece automáticamente una conexión con VS Code. Dado que el sensor de visión de inteligencia artificial solo puede mantener una conexión a la vez, esto evita que se conecte a VEXcode. Podrás ver el sensor de visión de IA en la extensión VEX VS Code una vez que se conecte a VS Code.

El sensor de visión de inteligencia artificial se mostrará cuando intente conectarse dentro de VEXcode V5 basado en web, pero seleccionarConectar no hará nada.

Para resolver este problema, cierre la aplicación VS Code y vuelva a conectar su sensor de visión IA. Si está utilizando VEXcode V5 basado en aplicación, el sensor de visión AI se conectará automáticamente.

Problema: El sensor de visión de IA no detecta correctamente durante los proyectos

Causa potencial

En los proyectos, el cerebro V5 depende de instantáneas frecuentes para obtener datos actuales del sensor de visión de inteligencia artificial. Sin actualizaciones regulares, el cerebro puede utilizar información obsoleta.

Cuando un robot u objeto se mueve demasiado rápido, puede pasar por el sensor de visión de IA antes de que se pueda capturar una nueva instantánea.

Solución

Para mitigar este problema, considere dos enfoques:

Reduce el tiempo del bloque Espera para capturar instantáneas con más frecuencia. Esto permite que el sensor de visión IA recopile datos con mayor frecuencia a medida que se produce movimiento.

Reduzca la velocidad del robot para permitir que el sensor de visión de IA tome más instantáneas durante el movimiento, aumentando la cantidad de datos recopilados.

Problema: Vision Utility tiene un color incorrecto

Causa potencial

La vista del sensor de visión de IA puede tintarse si se ve obstruida por un objeto cuando está conectado a la computadora o cuando la Utilidad de visión de IA se deja abierta durante demasiado tiempo.

Solución

Para solucionar esto, desconecte y vuelva a conectar el sensor de visión de IA a su computadora.

Esto activará la función de balance de blancos automático del sensor de visión de IA, que se activa cada vez que se enciende el dispositivo.

Problema: Detección de objetos no deseados en segundo plano

Posibles causas

  1. El sensor de visión IA no está orientado hacia el campo.
  2. Hay objetos en el fondo que AI Vision puede ver.
  3. La firma de color no es lo suficientemente específica y detecta colores similares cercanos.
  4. La iluminación en el campo es inconsistente.

Soluciones

Solución para la posible causa 1

Verifique la posición de montaje de su sensor de visión IA. Para un rendimiento óptimo, móntelo en ángulo hacia abajo, en dirección al campo. Esto garantiza que sólo detecte objetos dentro del campo, no áreas circundantes. 

Solución para la posible causa 2

La interferencia visual alrededor del sensor de visión de IA puede provocar errores de detección. Los objetos del área circundante (como carteles o ropa) que coincidan con la firma de color deseada pueden ser identificados por error por el sensor. Para obtener más información sobre cómo minimizar la interferencia visual en su configuración de campo, consulte Configuración del entorno del aula para usar el sensor de visión de IA.

Solución para la posible causa 3

Si una Firma de color no está configurada con un nivel de Tono y/o Saturación lo suficientemente amplio, no detectará correctamente la Firma de color de un objeto o detectará colores que pertenecen a objetos incorrectos. Lea Configuración de firmas de color con el sensor de visión de IA en VEXcode V5 o mire Ajuste de una firma de color en PD+ para obtener más información sobre cómo configurar una firma de color para que el sensor de visión de IA detecte con precisión el color deseado.

Solución para la posible causa 4

Las condiciones de iluminación pueden afectar significativamente el tono y la saturación de un color. Al configurar una Firma de color, los valores cambiarán dependiendo de la cantidad actual de luz sobre el objeto.

Si la cantidad de luz cambia, es posible que la misma firma de color no se detecte con tanta precisión.

Para solucionar esto, asegúrese de que el lugar donde se configura la firma de color del sensor de visión de IA sea el mismo que el lugar donde se utilizará el sensor en el campo, de modo que la detección de la firma de color permanezca constante.

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