The VEX Visual Studio Code Extension has replaced VEXcode Pro V5, which is now end-of-life.

VEXcode Blocks and VEXcode Text remain actively developed and supported for all VEX platforms.

VEXcode Pro V5는 사용자에게 경험이 풍부한 프로그래머가 되어 진정한 프로그래밍 경험을 제공합니다. 블록 기반 언어에서 전환 중이거나 숙련된 텍스트 기반 프로그래머인지 여부에 관계없이 다음 문서에서는 VEXcode Pro V5 사용자 인터페이스(UI)의 주요 기능을 다룹니다.

VEXcode Pro V5 인터페이스는 파일 메뉴, 툴바 아이콘, 코드 편집기, 파일 트리, 출력 패널 및 미니맵을 포함한 UI 요소들에 레이블이 지정된 모습을 보여줍니다.

윈도우

VEXcode Pro V5의 Windows 인터페이스가 열려 있으며, 새로 만들기, 열기, 예제 열기, 가져오기, 내보내기 및 저장 옵션이 포함되어 있습니다.

맥

VEXcode Pro V5 Mac 인터페이스에서 파일 메뉴가 열려 있으며, 새로 만들기, 열기, 예제 열기, 가져오기, 내보내기 및 저장 옵션이 표시됩니다.

파일을 선택하면 다음 옵션이 포함된 파일 메뉴 가 열립니다.

윈도우

VEXcode Pro V5의 창 편집 메뉴에는 실행 취소, 다시 실행, 잘라내기, 복사, 붙여넣기, 찾기 및 바꾸기를 포함한 옵션이 표시됩니다.

맥

VEXcode Pro V5 Mac의 편집 메뉴에는 실행 취소, 다시 실행, 잘라내기, 복사, 붙여넣기, 찾기 및 바꾸기를 포함한 옵션이 표시됩니다.

편집을 선택하면 편집 옵션의 편집 메뉴 이 열립니다.

윈도우

VEXcode Pro V5의 Windows 도구 메뉴에는 명령 팔레트, 문서 서식 및 주석 컨트롤을 포함한 옵션이 표시됩니다.

맥

VEXcode Pro V5 Mac 도구 메뉴에는 명령 팔레트, 문서 서식 및 주석 제어 기능을 포함한 옵션이 표시됩니다.

도구를 선택하면 다음 옵션 중 도구 메뉴 이 열립니다.

  • 파일 트리 축소 파일 트리 패널을 최소화하여 편집 영역을 넓힙니다.

VEXcode Pro V5 인터페이스에서 프로젝트 슬롯 선택기가 표시되며, 1번부터 8번까지의 슬롯을 다운로드할 수 있습니다.

프로젝트 슬롯 사용하면 사용자가 프로젝트를 다운로드할 브레인의 8개 슬롯 중 하나를 선택할 수 있습니다.

VEXcode Pro V5 프로젝트 세부 정보 창에는 프로젝트 이름, 설명, 자동 완성 및 로봇 구성과 같은 전문가 옵션이 표시됩니다.

프로젝트 이름 사용하면 사용자가 쉽게 참조할 수 있도록 프로젝트에 이름을 지정할 수 있습니다.

  • 프로젝트 이름을 클릭하면 클릭하여 전문가 옵션을 활성화할 수 있는 프로젝트 세부정보가 열립니다. 
  • 컨트롤러 표시기 는 컨트롤러가 연결되지 않은 경우 회색으로 표시되고, 연결되어 있지만 뇌에 대한 무선 연결이 없는 경우 주황색, 뇌에 연결되면 녹색으로 표시됩니다. 
  • 브레인 정보 V5 로봇 브레인이 UI에 연결되었는지(녹색), 연결되지 않았는지(회색), 업데이트가 필요한지(주황색 경고 삼각형이 있는 녹색 브레인)를 표시합니다.

VEXcode Pro V5 툴바에서, 컴퓨터에 아무것도 연결하지 않은 상태일 때 '프로젝트 다운로드' 버튼과 '빌드' 버튼의 위치를 ​​보여줍니다.

프로젝트 다운로드 뇌가 연결되었을 때 나타나는 버튼으로, 사용자가 프로젝트를 뇌에 다운로드할 수 있습니다.

참고: 두뇌가 연결되지 않은 경우 다운로드 버튼은 여기에 표시된BUID 버튼으로 대체됩니다.

  • Run 사용하면 프로젝트가 이미 로봇에 다운로드된 후 UI를 통해 프로젝트를 시작할 수 있습니다.
  • Stop 사용자가 UI를 통해 프로젝트를 중지할 수 있습니다.
  • Robot Config 사용자가 로봇 빌드에 포함된 장치를 추가, 제거 및 수정할 수 있도록 로봇의 구성을 표시합니다.
  • 도움말 사용자에게 개별 명령 도움말 및/또는 명령 참조를 제공합니다.
  • 피드백 통해 사용자는 UI 경험을 평가하고 VEX에 직접 메시지를 보낼 수 있습니다.
  • Split Editor 는 UI에 프로젝트 내의 서로 다른 두 파일을 보거나 동일한 파일의 서로 다른 부분을 볼 수 있는 두 개의 탭이 있도록 편집 화면을 분할하는 데 사용됩니다.
  • 미니맵 는 현재 편집기 창에 소스 파일의 어느 부분이 표시되어 있는지 보여주며, 강조 표시된 부분을 드래그하여 전체 파일을 빠르게 스크롤할 수 있습니다.
  • 파일 트리 는 사용자가 편집하려는 입력 파일을 선택할 수 있도록 프로젝트 내에서 사용되는 폴더 및 해당 파일 목록을 사용자에게 제공합니다.
  • 출력 탭 축소 출력 탭을 최소화하여 편집 영역을 확대합니다.
  • 출력 에는 저장, 컴파일 및 생성된 오류에 대한 정보가 나열됩니다.
  • 문제 에는 오류, 경고 및 문제에 대한 정보가 나열되어 있습니다. 
  • 터미널 는 뇌가 직접 USB 또는 컨트롤러를 통해 연결된 경우 뇌에서 실행되는 사용자 프로젝트에서 인쇄된 텍스트를 표시합니다. 또한 연결되면 사용자가 뇌에서 실행되는 프로젝트에 텍스트를 보낼 수 있습니다.
  • Clear 사용하면 사용자가 출력 및 터미널 디스플레이에서 메시지를 삭제할 수 있습니다.  

관련 기사:

For more information, help, and tips, check out the many resources at VEX Professional Development Plus

Last Updated: