VEXcode V5 4.0의 새로운 기능

VEXcode V5 4.0에는 다양한 새로운 기능이 도입되었습니다. 이 주요 업데이트는 로봇 코딩의 생산성과 접근성을 향상시키는 데 중점을 두고 있습니다. VEXcode V5 4.0에서 어떤 새로운 기능을 사용할 수 있는지 아래에서 알아보세요!

여기를 클릭하여 VEXcode V5 4.0의 새로운 설치 프로그램을 다운로드하세요!

스위치 블록

새로운 스위치 블록이 출시되어 블록 기반 코딩에서 텍스트 기반 프로그래밍으로의 전환이 매끄럽게 이루어집니다.

VEXcode V5에서 스위치 블록을 툴박스에서 워크스페이스로 드래그하는 모습이 화면에 표시됩니다. 사용자가 스위치 블록을 선택하고 파이썬 명령어를 입력하기 시작합니다.

드래그 앤 드롭 스위치 블록: 모든 스위치 블록은 도구 상자에서 드래그하여 직접 입력할 수 있습니다.

스위치 블록은 VEXcode V5 워크스페이스에 표시됩니다. 사용자가 자동 ​​수정 기능을 사용하여 파이썬 명령어 전체를 코드 블록에 입력하고 있습니다. 명령어는 drivetrain.turn_for(LEFT, 90, DEGREES)입니다.

블록 프로젝트에 Python을 직접 입력하세요: VEXcode를 사용하면 Python 명령을 프로젝트에 직접 통합하여 다른 블록과 원활하게 통합할 수 있습니다. 올바른 코드를 작성할 수 있도록 VEXcode는 Python 명령에 대한 자동완성 기능도 제공합니다.

VEXcode V5 워크스페이스에 모션 블록들이 쌓여 있는 모습이 표시됩니다. 사용자가 스택을 마우스 오른쪽 버튼으로 클릭하여 컨텍스트 메뉴를 열고 "스택을 스위치 블록으로 변환" 옵션을 선택합니다. 세 개의 블록이 쌓여 있는 구조가 세 줄의 파이썬 코드로 이루어진 하나의 Switch 블록으로 변환됩니다.

코드 변환: 한 번의 클릭으로 전체 블록 스택을 Python으로 변환합니다.

이 기능은 블록에서 텍스트로 넘어가려는 학습자에게 적합합니다. Switch Blocks로 코딩하는 것에 대한 자세한 내용은 여기를 참조하세요.


웹 기반 VEX코드에서 저장 및 로드

VEXcode V5 툴바의 프로젝트 이름 필드에 프로젝트가 저장될 때 업데이트되는 저장 메시지가 표시됩니다. 처음에는 "저장되지 않음"이라는 메시지가 표시되고, 그 다음에는 "저장 중", 마지막으로 "저장됨"이라고 표시됩니다.

웹 기반 VEXcode는 이제 프로젝트를 처음 저장하면 프로젝트 변경 사항을 자동으로 저장합니다.

파일 메뉴의 기타 변경 사항:

  • 장치에서 로드 이 이제열기로 변경되었습니다.
  • 기기에 저장 이 이제다른 이름으로 저장으로 변경되었습니다.
  • 이제 저장 버튼을 사용하여 수동으로 저장할 수도 있습니다.

Chrome 브라우저에서 VEXcode V5 프로젝트를 로드하고 저장하는 방법에 대한 단계별 가이드는 여기를 참조하세요.


업데이트된 AI 비전 센서 감지

AI 비전 센서는 이제 AprilTags와 AI 분류를 감지할 수 있습니다.

VEXcode V5의 AI Vision Utility 메뉴는 AprilTag 세 개를 캡처하는 카메라의 실시간 영상을 표시합니다. AprilTags 기능은 켜져 있고, AI 분류 기능은 꺼져 있습니다. 인식된 태그에는 각각의 ID, 좌표 및 크기가 표시됩니다.

AprilTags는 감지 가능하고 고유한 ID를 갖는 이미지입니다. 이를 인쇄하여 현장에서 로봇에 사용할 수도 있습니다. 인쇄 가능한 AprilTag PDF를 여기에서 다운로드하세요.

VEXcode V5의 AI 비전 유틸리티 메뉴. 메뉴에는 감지된 네 개의 객체(파란색 원 두 개, 빨간색 원 하나, 움직이는 목표물)가 표시된 실시간 카메라 영상이 나옵니다. 각 객체는 경계 상자로 색상, 위치, 크기 및 신뢰도 점수가 표시됩니다. 오른쪽 패널에는 AprilTags 및 AI 분류를 활성화하는 옵션이 있으며, AI 분류 모드는 '교실 요소'로 설정되어 있습니다.

AI 분류 모델에는 다양한 색상의 공, 링, 큐브를 감지하는 데 교육 환경에서 사용할 수 있는 Classroom Elements와 현재 VEX Robotics Competition(V5RC) 2024-2025 High Stakes 게임에서 게임 요소를 감지하는 데 사용할 수 있는 Competition Elements가 포함됩니다.

여기를 클릭하여 블록, Python, C++에서 AI 비전 센서를 사용하는 방법을 알아보세요.


블록을 소리내어 읽어보세요

VEXcode V5 4.0 내부의 모든 블록을 이제 간단히 마우스 오른쪽 버튼을 클릭하기만 하면 소리내어 읽을 수 있습니다.

이 기능은 Android를 제외한 모든 기기에서 사용할 수 있습니다.

VEXcode V5 드라이브 블록이 컨텍스트 메뉴가 열린 상태로 표시됩니다. 위에서 아래로 순서대로 나열된 옵션은 복제, 블록 비활성화, 블록 삭제, 블록 도움말, 블록을 스위치 블록으로 변환, 블록 읽기입니다. 읽기 블록 옵션이 강조 표시되어 있습니다.

  • 사용자 정의 음성: 새로운 도구 메뉴에서 다양한 음성을 선택하고 속도와 피치를 조정하세요.
  • 컨텍스트 메뉴 통합: 블록을 마우스 오른쪽 버튼으로 클릭하면 소리내어 읽힙니다.

VEXcode의 읽기 기능을 사용하는 방법에 대한 단계별 지침은 여기를 참조하세요.


도구 메뉴

VEXcode V5 4.0에서는 도구 메뉴가 파일 메뉴에서 도구 모음으로 이동되었으며, 이제 생산성과 접근성을 위한 기능이 가득 담겨 있습니다.

VEXcode V5 툴바에서 도구 드롭다운 메뉴가 열린 모습입니다. 테마, 키보드 단축키, 음성 설정, VEXcode 사운드 관리, API 문서 등 다섯 가지 옵션이 표시됩니다.

키보드 단축키

도움말 문서를 시작, 중지, 열기 위한 새로운 키보드 단축키가 추가되었습니다.

스코틀랜드 사람 윈도우
VEXcode V5 Mac 툴바에서 도구 드롭다운 메뉴가 열리고 키보드 단축키 옵션이 선택된 모습입니다. 사용 가능한 키보드 단축키는 오른쪽에 있는 두 번째 드롭다운 메뉴에 표시되며, 시작, 중지, 도움말 열기 세 가지 옵션이 있습니다. 각 옵션에는 해당하는 키보드 단축키가 있습니다. 시작 단축키는 Command 키와 Return 키를 함께 누르는 것이고, 정지 단축키는 Command 키와 E 키를 함께 누르는 것이며, 도움말 열기 단축키는 Command 키와 H 키를 함께 누르는 것입니다. VEXcode V5 윈도우 툴바에서 도구 드롭다운 메뉴가 열리고 키보드 단축키 옵션이 선택된 모습입니다. 사용 가능한 키보드 단축키는 오른쪽에 있는 두 번째 드롭다운 메뉴에 표시되며, 시작, 중지, 도움말 열기 세 가지 옵션이 있습니다. 각 옵션에는 해당하는 키보드 단축키가 있습니다. 시작 단축키는 Control 키와 Enter 키를 함께 누르는 것이고, 정지 단축키는 Control 키와 E 키를 함께 누르는 것이며, 도움말 열기 단축키는 Control 키와 H 키를 함께 누르는 것입니다.

고대비 테마

고대비 테마는 텍스트와 배경의 구분을 높여서 시력이 약하거나 색맹 또는 기타 시각 장애가 있는 사용자가 콘텐츠를 더 쉽게 읽을 수 있도록 합니다.

기본 높은 대비
VEXcode V5 블록 프로젝트로, 여러 카테고리의 블록을 사용하여 기본 색상 테마를 보여줍니다. VEXcode V5 블록 프로젝트로, 여러 카테고리의 블록을 사용하여 고대비 색상 구성표를 보여줍니다.

음성 설정

새로운 읽기 블록 기능을 사용하면 이 메뉴에서 사용되는 음성, 말하기 속도 및 피치를 변경할 수 있습니다.

VEXcode V5 음성 설정 창에는 음성을 선택하는 드롭다운 메뉴, 음높이와 속도를 변경하는 두 개의 슬라이더, 그리고 현재 음성 설정을 들어볼 수 있는 '음성 테스트' 버튼이 있습니다.

API 문서

포괄적인 API 문서에 액세스하면 그 어느 때보다 더 쉽게 VEX V5 로봇의 모든 잠재력을 탐색하고 활용할 수 있습니다.

VEXcode V5 API 문서 페이지에서 드라이브 파이썬 명령어에 대한 정보를 확인할 수 있습니다. API 페이지에는 각 블록 및 텍스트 명령에 대한 설명, 기능 및 예제 프로젝트가 포함되어 있습니다.

여기를 클릭하여 공식 VEX API 참조 사이트에 접속하세요.


웹 기반 무선 프로젝트 다운로드

웹 기반 VEXcode V5는 이제 V5 컨트롤러를 통해 V5 Brain에 무선으로 연결할 수 있습니다.

녹색으로 강조 표시된 컨트롤러 아이콘이 있는 VEXcode V5 툴바입니다.

V5 Brain에 프로젝트를 무선으로 다운로드하는 방법을 알아보려면 여기를 클릭하세요.

For more information, help, and tips, check out the many resources at VEX Professional Development Plus

Last Updated: