The VEX AIR Drone and VEX AIR Drone Controller are designed to work together to provide stable flight and precise control during flight and in the VEX AIR Flight Simulator. In most cases, issues with flight behavior, responsiveness, or stability are caused by configuration, connection, or hardware setup.
If the drone or controller is not behaving as expected, use the troubleshooting steps in this article to identify and resolve common issues.
First Checks
Before troubleshooting specific issues, verify the following:
- All batteries have sufficient charge (> 30%). Follow the steps in this article to learn more about charging VEX AIR Drone Batteries and the controller battery.
- The controller is paired to the correct drone. If you are unsure which drone your controller is paired to, follow the steps in this article to pair your drone and controller.
- If using the VEX AIR Flight Simulator, ensure the controller is connected to your device. Follow the steps in this article to learn how to connect the controller to VEXcode AIR.
- Firmware on both the drone and controller is up to date. Follow the steps in this article to learn more about updating both the drone and the controller's firmware.
Many issues can be resolved by checking these items before moving to more detailed troubleshooting steps.
Quick Troubleshooting Guide
The table here summarizes some common situations. More details about each of the problems and possible solutions can be found below.
If this happens: |
Try this first: |
| Drone will not take off | Check propellers and ensure Propeller Lock is disengaged. |
| Drone does not respond to controller input | Confirm the correct drone and controller are paired. Restart both controller and the drone. |
| Controller is unresponsive | Restart the controller and the drone. Reset the controller. |
| Drone flight appears unstable | Verify Movement Mode settings on the controller and inspect propellers. |
| Drone will not reach expected height | Verify the Maximum Z Height settings on the controller. |
If you have an issue that falls outside of those listed here and have tried the other listed troubleshooting methods in this article, please contact VEX Support.
Potential Problems and Possible Solutions
The following section breaks down potential problems that have occurred with your drone or controller and explains possible causes of the problem and solutions to help you troubleshoot.
For your safety and the safety of those around you, ensure that the drone's propellers are stationary and Propeller Lock is engaged before beginning any troubleshooting.
Problem: Drone Will Not Take Off
Symptoms:
- The drone powers on but does not lift off.
- Propellers on the drone spin but the drone remains on the ground.
- Only some of the propellers spin.
Possible Causes:
- Propeller Lock is engaged.
- Propellers are damaged or incorrectly installed.
Solutions:
- Confirm that Propeller Lock is disengaged. Learn more about the Propeller Lock in this article.
- Inspect each propeller to ensure it spins freely, is securely attached, and is not damaged. Follow the steps in this article to clean or replace a propeller.
Problem: Drone Does Not Respond to Controller Input
Symptoms:
- The drone does not move when joysticks are moved.
- The controller appears connected but no movement occurs.
Possible Causes:
Controller is paired to the wrong drone.
Firmware is out of date.
Solutions:
- Begin by power cycling both the controller and drone.
- Remove the battery from the drone, re-insert the battery, and turn the drone on.
- Press and hold the Power button on the controller until the screen turns off. Wait 10 seconds, then press the Power button again to turn the controller back on.
- Confirm that the controller is paired to the correct drone. Follow the steps in this article to pair a drone and controller.
- Verify that the firmware is up to date on both devices.
- Begin by updating the controller firmware by following the steps in this article.
- Once controller firmware is updated, connect the drone and controller using a USB cable and any needed firmware updates will begin automatically.
Problem: Controller is Unresponsive
Symptoms:
- The controller screen does not respond to input.
- The controller joysticks and/or buttons do not respond to input.
- The LED indicator on the controller rapidly blinks red.
Possible Cause:
- Temporary software glitch. Hardware reset needed.
- Incomplete firmware update.
Solutions:
- If the drone is in flight, use the emergency stop protocol to safely stop the drone's propellers.
Pressing the Propeller Lock and Takeoff & Land buttons on the controller at the same time will immediately shut down the motors and cause the drone to fall to the ground, as shown in this animation.
- Power cycle the controller.
If the controller's screen is unresponsive, press and hold the Power button until the LED indicator begins blinking white, then release it. This will shut down the controller. Wait 10 seconds before turning the controller on again.
- If the controller's Power button is unresponsive, reset the controller using the steps below.
Insert a thin object (such as a paper clip) into the pinhole on the back of the controller and press the Reset button inside. Once the controller has powered off, wait 10 seconds and turn the controller back on.
- Verify that the firmware is up to date on the controller. Follow the steps in this article to update the controller's firmware.
Problem: Drone Flight Appears Unstable
Symptom:
- The drone drifts or wobbles while hovering.
- The drone struggles to maintain level height.
Possible Cause:
- Damaged propellers.
- Performance Movement Mode is selected.
Solution:
- Inspect each propeller to ensure it spins freely, is securely attached, and is not damaged. Follow the steps in this article to clean or replace a propeller.
- Verify the Movement Mode selected in the drone settings.
- Review how to change drone settings on the controller with this article.
- Performance mode is a high-speed, non-stabilized mode for advanced maneuvering. Use Precision or Balanced for more controlled movements.
Problem: Drone Will Not Reach Expected Height
Symptoms:
- The drone stops climbing even when the throttle is increased.
Possible Cause:
- Maximum Z Height limit is set too low.
Solution:
- Adjust the settings for the Maximum Z Height of the drone in the drone settings on the controller.
- Review how to change drone settings on the controller with this article.
- Only adjust this setting to allow a higher flight ceiling if appropriate for your flight area.