Troubleshooting VEX AIR

The VEX AIR Drone and VEX AIR Drone Controller are designed to work together to provide stable flight and precise control during flight. In most cases, issues with flight behavior, responsiveness, or stability are caused by configuration, connection, or hardware setup.

If the drone or controller is not behaving as expected, use the troubleshooting steps in this article to identify and resolve common issues.


Before You Begin Troubleshooting

First, verify that the drone and controller are charged, paired, and updated correctly.

VEX AIR Drone Battery with the battery status button highlighted beside the 4 LEDs on the bottom of the battery.

A VEX AIR Drone with a green indicator light on the right, and a VEX AIR Drone Controller with the connection screen showing on the left, with a question mark between the two.

VEXcode AIR Updating Firmware dialog box.

Many issues can be resolved by checking these items before moving to more detailed troubleshooting steps.


Troubleshooting Guide

The following section breaks down potential problems that have occurred with your drone or controller and explains possible causes of the problem and solutions to help you troubleshoot. 

Select the one that best matches your issue to view additional information and troubleshooting guidance.

For your safety and the safety of those around you, be sure that the drone's propellers are stationary and Propeller Lock is engaged before beginning any troubleshooting.


Problem: Drone is not taking off

A top down view of the VEX AIR Drone with the LED indicator on the power button glowing blue, indicating the Propeller Lock is on.

Symptoms: 

  • The drone powers on but does not lift off.
  • Propellers on the drone spin but the drone remains on the ground.
  • Only some of the propellers spin.

Possible Causes: 

  • Propeller Lock is active.
  • Propellers are damaged or incorrectly installed.

Solutions: 

  1. Confirm that Propeller Lock is deactivated. When the Propeller Lock safety feature is active the motors and propellers cannot start for any reason. Projects like the default_fly  project can be started, but all other flight commands will be ignored. The LED indicator on the drone flashes blue when the Propeller Lock is activated. Learn more about the Propeller Lock, including how to deactivate it, in this article.
  2. Inspect each propeller to ensure it spins freely, is securely attached, and is not damaged. If the propellers are not functioning properly the drone may not be able to create enough lift to take off. Follow the steps in this article to clean or replace a propeller.

Problem: Drone is not responding to controller input

A drone and controller are side by side. On the left, the right joystick is moving upwards, but the drone on the right is not responding.

Symptoms: 

  • The drone does not move when joysticks are moved.
  • The controller appears connected but no drone movement occurs.

Possible Causes: 

  • Controller is paired to the wrong drone.

  • Firmware is out of date.

Solutions: 

  1. Power cycle both the controller and drone. At times, power cycling can help reset the hardware.
    • Remove the battery from the drone, re-insert the battery, and turn the drone on.
    • Press and hold the Power button on the controller until the screen turns off. Wait 10 seconds, then press the Power button again to turn the controller back on. 
  2. Confirm that the controller is paired to the correct drone. The controller will automatically connect to the drone it was most recently paired to. If that is not the drone you are currently using, the controller will need to be re-paired in order to fly. Follow the steps in this article to pair a drone and controller.
  3. Verify that the firmware is up to date on both the controller and drone. Keeping firmware up to date helps ensure that the drone and controller perform as intended.
    • Begin by updating the controller firmware in VEXcode AIR by following the steps in this article.
    • Once controller firmware is updated, connect the drone and controller using a USB cable and any needed firmware updates will begin automatically.

Problem: Controller is unresponsive

A VEX AIR Drone Controller with the Display screen of the default fly project showing and the LED indicator showing red.

Symptoms: 

  • The controller screen does not respond to input.
  • The controller joysticks and/or buttons do not respond to input.
  • The LED indicator on the controller rapidly blinks red.

Possible Cause: 

  • Temporary software glitch. Hardware reset needed.
  • Incomplete firmware update.

Solutions: 

  1. Stop flying and power cycle the controller. At times, power cycling can help reset the hardware. If the drone is in flight, use the Emergency Stop (E-Stop) protocol to safely stop the drone's propellers.

Press the Propeller Lock and Takeoff & Land buttons on the controller at the same time to immediately shut down the motors and cause the drone to fall to the ground, as shown in this animation. 

Once the drone landed, power cycle the controller. Press and hold the Power button until the LED indicator begins blinking white, then release it. This will shut down the controller. Wait 10 seconds before turning the controller on again.

  1. If the controller's Power button is unresponsive, reset the controller.  At times you may have to reset the controller to return it to its expected functionality. 

Rear view of a VEX drone controller with a yellow highlight marking the small reset button located in the center of the controller’s back panel.

Follow these steps to reset the controller: 

  • Insert a thin object (such as a paper clip) into the pinhole on the back of the controller and press the Reset button inside. 
  • Once the controller has powered off, wait 10 seconds. 
  • Turn the controller back on.
  1. Verify that the firmware is up to date on the controller. Keeping firmware up to date helps ensure that the controller performs as intended. Follow the steps in this article to update the controller's firmware.

Problem: Drone is flying faster or slower than expected

Two VEX AIR Drones fly side by side, the one on the left moving more slowly, and the one on the right moving more quickly and zigzagging.

Symptom:

  • The drone drifts wildly while hovering and/or struggles to maintain level height.
  • The drone moves and turns more quickly or slowly than expected when controller joysticks are moved.

Possible Cause:

  • Damaged propellers.
  • A different Movement Mode is selected.

Solution:

  1. Verify the Movement Mode selected in the drone settings. The Movement Mode will stay from one flight session to the next, so if the controller was previously set to a different Movement Mode it may still be on that setting. Each Movement Mode provides a different amount of stability assist and flight speed, from Precision (slowest), to Balanced (somewhat faster), to Performance (high-speed, non-stabilized). Learn how to change drone settings, like Movement Mode, on the controller with this article.
  2. Inspect each propeller to ensure it spins freely, is securely attached, and is not damaged. If the propellers are not functioning properly the drone may not be able to maintain control or move accurately. Follow the steps in this article to clean or replace a propeller.

Problem: Drone is not flying to desired height

The VEX AIR Drone Controller screen with the Drone Settings menu open in the lower right quadrant. The first option reads Z Height Limit and is set to 3.5m.

Symptoms:

  • The drone stops climbing even when the throttle is increased.

Possible Cause:

  • Maximum Z Height Limit is set too low.

Solution:

  1. Adjust the settings for the Maximum Z Height of the drone in the drone settings on the controller. The Z Heigh Limit setting stays from one flight session to another, so if it was changed previously, it may need to be adjusted for your current flight.

If you have an issue that falls outside of those listed here and have tried the other listed troubleshooting methods in this article, please contact VEX Support.

For more information, help, and tips, check out the many resources at VEX Professional Development Plus

Last Updated: