VEXcode Pro V5 为用户提供真实的编程体验当它们成为更有经验的程序员时。 无论你从基于指令块的语言过渡还是是一个有经验的文本程序员,以下文章将涵盖 VEXcode Pro V5 用户界面的主要功能。

VEXcode_V5_Text_UI_新_v5.jpg

Windows

文件_菜单.png

Mac

文件_菜单_Mac.png

选择“File”来打开带有以下选项的文件菜单

Windows

编辑_菜单.png

Mac

编辑_菜单_Mac.png

选择“Edit”打开编辑选项的编辑菜单

Windows

工具_菜单.png

Mac

工具_菜单_最大.png

选择“Tool”打开以下选项的工具菜单

  • 折叠文件树将最小化文件树面板以扩大编辑区。

槽位.png

程序槽位允许用户来选择主控器上八个槽位中的一个,来下载程序到此处。

启用专家.png

程序名称允许用户来分配一个易于参考的程序名称。

  • 点击程序名称将打开程序详细信息,在这里你可以点击启用专家选项。
  • 如果没有连接遥控器,遥控器指示灯将是灰色,如果已连接但是没有无线连接到主控器是橙色,以及已连接到主控器是绿色。
  • 主控器信息显示了 V5 主控器是否已连接(绿色)到用户界面,未连接(灰色),或需要更新(绿色主控器带橙色三角形警告图标)。

编译裁剪.png

下载程序是当主控器已连接时显示的按钮,以便用户可以下载程序到主控器。

注意:当主控器未连接时,下载按钮被搭建按钮替换,如此处所示:

  • Run允许用户通过用户界面开始程序,在它已经被下载到主控器后。
  • Stop允许用户通过用户界面来停止程序。
  • Robot Config展示了机器人的配置以便用户可以添加,移除,以及更改包含在机器人搭建中的设备。
  • Help为用户提供了单独的指令帮助和/或提供了指令参考。
  • Feedback让用户评价他们对用户界面的体验并直接通知 VEX。
  • Split Editor用于分离编辑屏幕以便于用户界面项目窗口中查看两个不同的程序窗口,或去看同一个文件的不同部分。
  • Mini Map显示用户当前源文件正在编辑窗口中显示的部分并且允许用户通过拖动高亮部分快速滚动整个文件。
  • 文件树为用户提供了一列文件夹以及在项目中使用的文件,以便于用户可以选择他们想要编辑的输入文件。
  • Collapse Output Tabs将最小化输出窗口来扩大编辑区域。
  • Output列出关于保存,编译,以及生成错误的信息。
  • Problems列出错误,告警,以及关于问题的信息。
  • 当主控器通过 USB直接或遥控器连接时,Terminal显示从主控器上正在运行的一个用户程序打印的文本。 它也允许用户在已连接时发送文本到正在主控器上运行的程序。
  • Clear让用户从输出和终端显示中删除消息。

相关文章:

For more information, help, and tips, check out the many resources at VEX Professional Development Plus