Завантаження та збереження проекту VEXcode VR у Windows

Проект можна завантажити та зберегти у VEXcode VR кількома способами.

Примітка: через обмеження браузера різні веб-браузери відображатимуть різні варіанти збереження та завантаження. Обов’язково дотримуйтесь інструкцій, які стосуються вашого браузера. Не бачите свій браузер у списку? Переконайтеся, що ваш браузер підтримує VEXcode VR тут.


Перевірте сумісність з автозбереженням

Сумісність веб-переглядача для автозбереження різна. Щоб визначити, чи підтримує ваш браузер цю функцію, виконайте такі дії:

Кнопка «Проєкт» на панелі інструментів VEXcode VR для відкриття меню завантаження та збереження

Виберіть назву проекту.

Діалогове вікно збереження, що показує підтримку автоматичного збереження браузера для проєкту VEXcode VR.

Якщо веб-браузер підтримує автозбереження, з’явиться повідомлення Браузер із можливістю автозбереження.

Якщо доступне автозбереження, VEXcode автоматично збереже всі зміни, коли ви відкриєте або спочатку збережете проект на своєму комп’ютері.

Діалогове вікно збереження Windows з вибраним параметром «Автозбереження недоступне» для VR-проекту VEXcode

Якщо веб-браузер не підтримує автозбереження, з’явиться повідомлення Автозбереження недоступне.

Якщо автозбереження недоступне, ви повинні вручну зберігати свій проект після кожної зміни, щоб запобігти втраті даних.

Перегляньте розділ «Зберегти за допомогою меню «Файл»» цієї статті, щоб дізнатися, як зберегти свій проект.


Відкрийте існуючий проект

Google Chrome або Microsoft Edge

Меню «Файл» з опціями «Відкрити проект» та «Зберегти на пристрої» у VEXcode VR на Windows

Завантажте існуючий проект, вибравши Openу меню File.

Відкрити діалогове вікно з вибраним файлом Drive Forward.vrblocks у папці «Завантаження»

Використовуйте інтерфейс Windows для навігації та відкриття існуючого проекту VEXcode VR. 

Firefox

Опція меню «Файл» для завантаження проєкту з вашого пристрою (Ctrl+O)

Завантажте існуючий проект, вибравши Завантажити зі свого пристрою у меню «Файл».

Відкрити діалогове вікно з вибраним файлом Drive Forward.vrblocks у папці «Завантаження»

Використовуйте інтерфейс Windows для навігації та відкриття існуючого проекту VEXcode VR.


Відкрийте приклад проекту

Меню «Файл» з опціями «Завантажити з вашого пристрою» та «Зберегти на вашому пристрої» у VEXcode VR

Відкрийте приклад проекту, вибравши Відкрити приклади у меню «Файл». Цей текст однаковий для всіх браузерів.

Щоб дізнатися більше про використання прикладів проектів у VEXcode VR, перегляньте цю статтю.


Перейменувати проект

Google Chrome або Microsoft Edge

Кнопка «Проєкт» на панелі інструментів VEXcode VR для відкриття меню завантаження та збереження

Щоб перейменувати проект, виберіть вікно «Назва проекту».

Діалогове вікно «Зберегти проект як» з вибраним полем назви проекту у Windows

Текст у вікні «Назва проекту» буде виділено. Введіть нову назву вашого проекту.

Діалогове вікно «Зберегти як» у Windows із полем назви VR-проекту VEXcode

Після зміни назви проекту кнопка Зберегти стане доступною.

Виберіть Зберегти.

Діалогове вікно «Зберегти як», у якому перед збереженням відображається назва проекту Robot Drive.vrblocks.

Перейдіть до місця, де ви хочете зберегти проект, і виберіть Зберегти.

Меню «Файл» з опціями «Завантажити з вашого пристрою» та «Зберегти на вашому пристрої» у VEXcode VR

Індикатор автозбереження праворуч від назви проекту тепер зміниться на Збережено.

Діалогове вікно «Зберегти як», яке показує, де ввести назву проекту та зберегти проект VEXcode VR.

Тепер, коли ви виберете вікно «Назва проекту», кнопка«Зберегти зміниться на кнопку«Зберегти як.

Firefox

Кнопка «Проект» відкриває меню VR-проекту VEXcode

Щоб перейменувати проект, виберіть вікно «Назва проекту».

Діалогове вікно збереження з активним полем назви проєкту та вимкненим полем «Збереження», доки не буде введено назву.

Текст у вікні «Назва проекту» буде виділено. Введіть нову назву вашого проекту.

Діалогове вікно збереження, що показує назву проекту VEXcode VR перед збереженням файлу

Після зміни назви проекту кнопка Зберегти стане доступною. ВиберітьЗберегти , щоб застосувати нову назву до свого проекту.

Кнопка «Зберегти на пристрої» на панелі інструментів VEXcode VR

Назва проекту зміниться у верхній частині проекту.

Важливо: Firefox не підтримує автозбереження. Зміни в назві проекту не буде збережено, доки ви вручну не збережете проект на своєму пристрої.


Зберегти за допомогою меню «Файл».

Google Chrome або Microsoft Edge

Меню «Файл» з опціями «Завантажити з вашого пристрою» та «Зберегти на вашому пристрої» у VEXcode VR

Відкрийте меню «Файл» і виберіть «Зберегти або«Зберегти як.

Меню «Файл» із командою «Зберегти» та комбінацією клавіш Ctrl+S у VEXcode VR

Відобразиться діалогове вікно. Перейдіть до місця, де ви хочете зберегти свій проект VEXcode, і виберітьЗберегти.

Файл Project.vrblocks, вибраний у Завантаженнях для імпорту у VEXcode VR

Ваш файл буде збережено у вибраному місці.

Firefox

Меню «Файл» із опцією «Зберегти на пристрій» за допомогою комбінації клавіш Ctrl+S

Відкрийте меню «Файл» і виберіть Зберегти на свій пристрій.

Завантаження VEXcode Project.vrblocks завершено, з опцією відображення файлу в його папці

Сповіщення про збереження з’явиться у верхній частині браузера.

Файл Project.vrblocks, вибраний у Завантаженнях для імпорту у VEXcode VR

Ваш файл буде збережено у вибраному місці.

Важливо: Firefox не підтримує автозбереження. Зміни проекту не буде збережено, доки ви вручну не збережете проект на своєму пристрої.


Поширена проблема під час завантаження/збереження

Запит Windows повідомляє, що файл не має пов'язаної програми, і спрямовує користувача до налаштувань програм за замовчуванням.

Поширеною проблемою під час використання файлів проекту VEXcode є спроба вибрати файл проекту, який буде відкрито безпосередньо операційною системою.

Діалогове вікно Windows із запитом, яка програма має відкрити файл проекту .vrblocks

Якщо ви спробуєте відкрити файл проекту VEXcode, двічі клацнувши його, з’явиться це повідомлення про помилку.

Щоб правильно відкрити ці файли, будь-які файли VEXcode VR потрібно відкрити у VEXcode VR.

For more information, help, and tips, check out the many resources at VEX Professional Development Plus

Last Updated: