VEXcode Pro V5'e Genel Bakış

The VEX Visual Studio Code Extension has replaced VEXcode Pro V5, which is now end-of-life.

VEXcode Blocks and VEXcode Text remain actively developed and supported for all VEX platforms.

VEXcode Pro V5, kullanıcılara daha deneyimli programcılar haline geldikçe özgün bir programlama deneyimi sunar. İster blok tabanlı bir dilden geçiş yapıyor olun ister deneyimli bir metin tabanlı programcı olun, aşağıdaki makale VEXcode Pro V5 Kullanıcı Arayüzünün (UI) ana işlevlerini kapsayacaktır.

VEXcode Pro V5 arayüzü, dosya menüsü, araç çubuğu simgeleri, kod düzenleyici, dosya ağacı, çıktı paneli ve mini harita dahil olmak üzere etiketlenmiş kullanıcı arayüzü öğelerini göstermektedir.

pencereler

VEXcode Pro V5 Windows arayüzü, Yeni, Aç, Örnekleri Aç, İçe Aktar, Dışa Aktar ve Kaydet seçeneklerini içeren Dosya menüsünün açık halini göstermektedir.

Mac

VEXcode Pro V5 Mac arayüzü, Yeni, Aç, Örnekleri Aç, İçe Aktar, Dışa Aktar ve Kaydet seçeneklerini içeren Dosya menüsünün açık halini göstermektedir.

Dosya seçildiğinde aşağıdaki seçeneklerle birlikte Dosya Menüsü açılır:

pencereler

VEXcode Pro V5 Windows Düzenleme menüsünde Geri Al, Yinele, Kes, Kopyala, Yapıştır, Bul ve Değiştir seçenekleri gösterilmektedir.

Mac

VEXcode Pro V5 Mac'in düzenleme menüsünde Geri Al, Yinele, Kes, Kopyala, Yapıştır, Bul ve Değiştir gibi seçenekler gösterilmektedir.

Düzenle seçildiğinde düzenleme seçeneklerinin Düzenleme Menüsü açılır

pencereler

VEXcode Pro V5 Windows Araçlar menüsünde Komut Paleti, Belge Biçimlendirme ve yorum denetimleri gibi seçenekler gösterilmektedir.

Mac

VEXcode Pro V5 Mac Araçlar menüsünde Komut Paleti, Belge Biçimlendirme ve yorum kontrolleri gibi seçenekler gösterilmektedir.

Araçlar seçildiğinde aşağıdaki seçeneklerden Araçlar Menüsü açılır

  • Dosya Ağacını Daralt seçeneği, düzenleme alanını genişletmek için Dosya Ağacı Panelini küçültür.

VEXcode Pro V5 arayüzü, indirilmeye hazır 1'den 8'e kadar olan yuvaları gösteren proje yuvası seçiciyi sergiliyor.

Proje Yuvası kullanıcıların Beyindeki sekiz yuvadan birini projenin indirileceği yere seçmesine olanak tanır.

VEXcode Pro V5 Proje Ayrıntıları penceresi, proje adını, açıklamasını ve otomatik tamamlama ve robot yapılandırması dahil olmak üzere uzman seçeneklerini gösterir.

Proje Adı kullanıcıların kolay başvuru için projeye bir ad atamasına olanak tanır.

  • Proje Adına tıklamak, uzman seçeneklerini etkinleştirmek için tıklayabileceğiniz Proje Ayrıntılarını açacaktır. 
  • Denetleyici Göstergesi hiçbir denetleyici bağlı değilse gri, bağlıysa ancak beyne radyo bağlantısı yoksa turuncu ve beyne bağlıysa yeşil olacaktır. 
  • Beyin Bilgisi , V5 Robot Beyninin kullanıcı arayüzüne bağlı mı (yeşil), bağlı değil mi (gri) veya güncellenmesi gerekip gerekmediğini (turuncu uyarı üçgenli yeşil beyin) gösterir.

VEXcode Pro V5 araç çubuğu, hiçbir beyin bağlantısı olmadığında "Projeyi İndir" düğmesinin ve "Derle" düğmesinin konumunu gösteriyor.

Projeyi İndir , kullanıcıların projeyi beyne indirebilmesi için beyin bağlandığında ortaya çıkan butondur.

Not: Beyin bağlı olmadığında İndir düğmesinin yerini burada gösterilenBuild düğmesialır:

  • Çalıştır , kullanıcının projeyi robota indirdikten sonra kullanıcı arayüzü aracılığıyla başlatmasına olanak tanır.
  • Durdur kullanıcının kullanıcı arayüzü aracılığıyla projeyi durdurmasına olanak tanır.
  • Robot Yapılandırması robotun yapılandırmasını görüntüler; böylece kullanıcılar robot yapısında yer alan aygıtları ekleyebilir, kaldırabilir ve değiştirebilir.
  • Yardım kullanıcıya bireysel Komut Yardımı ve/veya Komut Referansı sağlar.
  • Geribildirim , kullanıcıların kullanıcı arayüzündeki deneyimlerini derecelendirmesine ve VEX'e doğrudan mesaj göndermesine olanak tanır.
  • Bölünmüş Düzenleyici kullanıcı arayüzünün proje içindeki iki farklı dosyaya bakmak veya aynı dosyanın farklı bölümlerine bakmak için iki sekmeye sahip olması amacıyla düzenleme ekranını bölmek için kullanılır.
  • Mini Harita kullanıcılara kaynak dosyanın hangi bölümünün o anda editör penceresinde görüntülendiğini gösterir ve kullanıcının vurgulanan bölümü sürükleyerek tüm dosyada hızlı bir şekilde gezinmesine olanak tanır.
  • Dosya Ağacı kullanıcılara proje içinde kullanılan klasörlerin ve bunların dosyalarının bir listesini sağlar, böylece kullanıcılar düzenlemek istedikleri giriş dosyasını seçebilirler.
  • Çıkış Sekmelerini Daralt , düzenleme alanını genişletmek için Çıkış Sekmelerini küçültecektir.
  • Çıkış kaydetme, derleme ve oluşturulan hatalar hakkındaki bilgileri listeler.
  • Sorunlar hatalar, uyarılar ve sorunlarla ilgili bilgileri listeler. 
  • Terminal beyin doğrudan USB veya denetleyici aracılığıyla bağlandığında, beyin üzerinde çalışan bir kullanıcı projesinden yazdırılan metni görüntüler. Ayrıca kullanıcının bağlandığında beyinde çalışan projeye metin göndermesine de olanak tanır.
  • Temizle kullanıcının Çıkış ve Terminal ekranlarından mesajları silmesini sağlar.  

İlgili Makaleler:

For more information, help, and tips, check out the many resources at VEX Professional Development Plus

Last Updated: