VEXcode Pro V5 Översikt

The VEX Visual Studio Code Extension has replaced VEXcode Pro V5, which is now end-of-life.

VEXcode Blocks and VEXcode Text remain actively developed and supported for all VEX platforms.

VEXcode Pro V5 ger användarna en autentisk programmeringsupplevelse allt eftersom de blir mer erfarna programmerare. Oavsett om du övergår från ett blockbaserat språk eller är en erfaren textbaserad programmerare, kommer följande artikel att täcka huvudfunktionerna i VEXcode Pro V5 användargränssnitt (UI).

VEXcode Pro V5-gränssnitt som visar märkta UI-element inklusive Arkiv-meny, verktygsfältsikoner, kodredigerare, filträd, utdatapanel och minikarta.

Fönster

VEXcode Pro V5 Windows-gränssnitt som visar Arkiv-menyn öppen med alternativ som Nytt, Öppna, Öppna exempel, Importera, Exportera och Spara.

Mac

VEXcode Pro V5 Mac-gränssnitt som visar Arkiv-menyn öppen med alternativ som Nytt, Öppna, Öppna exempel, Importera, Exportera och Spara.

Om du väljer Arkiv öppnas Arkiv-menyn med följande alternativ:

Fönster

VEXcode Pro V5 Windows redigeringsmeny som visar alternativ inklusive Ångra, Gör om, Klipp ut, Kopiera, Klistra in, Sök och Ersätt.

Mac

VEXcode Pro V5 Mac Redigera-meny som visar alternativ inklusive Ångra, Gör om, Klipp ut, Kopiera, Klistra in, Sök och Ersätt.

Om du väljer Redigera öppnas Redigera-menyn med redigeringsalternativ.

Fönster

VEXcode Pro V5 Windows Verktygsmeny som visar alternativ inklusive kommandopalett, formatera dokument och kommentarskontroller.

Mac

VEXcode Pro V5 Mac Verktygsmeny som visar alternativ inklusive kommandopalett, formatera dokument och kommentarskontroller.

Om du väljer Verktyg öppnas Verktygsmenyn av följande alternativ

  • Minimera filträd minimerar filträdspanelen för att förstora redigeringsområdet.

VEXcode Pro V5-gränssnittet visar projektplatsväljaren med platserna 1 till 8 tillgängliga för nedladdning.

Projektplats låter användare välja en av de åtta platserna på hjärnan dit projektet ska laddas ner.

VEXcode Pro V5 Projektinformationsfönster som visar projektnamn, beskrivning och expertalternativ inklusive autofullständig ifyllning och robotkonfiguration.

Projektnamn låter användare ge projektet ett namn för enkel referens.

  • Om du klickar på Projektnamn öppnas Projektdetaljer där du kan klicka för att aktivera expertalternativ. 
  • Styrenhetsindikator är grå om ingen styrenhet är ansluten, orange om den är ansluten men det inte finns någon radiolänk till hjärnan och grön när den är ansluten till hjärnan. 
  • Hjärninformation visar om V5-robotens hjärna är ansluten (grön) till användargränssnittet, inte ansluten (grå) eller behöver uppdateras (grön hjärna med orange varningstriangel).

VEXcode Pro V5-verktygsfältet som visar platsen för knappen Ladda ner projekt och knappen Bygg när ingen hjärna är ansluten.

Ladda ner projekt är knappen som visas när hjärnan är ansluten så att användare kan ladda ner projektet till hjärnan.

Obs: När hjärnan inte är ansluten ersätts nedladdningsknappen avBbuild-knappensom visas här:

  • Kör låter användaren starta projektet via användargränssnittet efter att det redan har laddats ner till roboten.
  • Stopp låter användaren stoppa projektet via användargränssnittet.
  • Robotkonfiguration visar robotens konfiguration så att användare kan lägga till, ta bort och modifiera de enheter som ingår i robotens byggsats.
  • Hjälp ger användaren individuell kommandohjälp och/eller tillhandahåller kommandoreferensen.
  • Feedback låter användare betygsätta sina upplevelser med användargränssnittet och skicka meddelanden direkt till VEX.
  • Dela redigeraren används för att dela redigeringsskärmen så att användargränssnittet har två flikar för att titta på två olika filer inom projektet, eller för att titta på olika delar av samma fil.
  • Minikarta visar användarna vilken del av källfilen som för närvarande visas i redigeringsfönstret och låter användaren snabbt bläddra igenom hela filen genom att dra det markerade avsnittet.
  • Filträd ger användarna en lista över mappar och deras filer som används i projektet så att de kan välja vilken indatafil de vill redigera.
  • Minimera utdataflikar minimerar utdataflikarna för att förstora redigeringsområdet.
  • Utdata listar information om sparande, kompilering och genererade fel.
  • Problem listar fel, varningar och information om problem. 
  • Terminal visar text som skrivits ut från ett användarprojekt som körs på hjärnan när hjärnan är ansluten via direkt USB eller kontrollenheten. Det låter också användaren skicka text till projektet som körs på hjärnan när den är ansluten
  • Rensa låter användaren radera meddelanden från utgångs- och terminaldisplayerna.  

Relaterade artiklar:

For more information, help, and tips, check out the many resources at VEX Professional Development Plus

Last Updated: