The VEX Visual Studio Code Extension has replaced VEXcode Pro V5, which is now end-of-life.

VEXcode Blocks and VEXcode Text remain actively developed and supported for all VEX platforms.

VEXcode Pro V5 предоставляет пользователям подлинный опыт программирования, поскольку они становятся более опытными программистами. Независимо от того, переходите ли вы с блочного языка или являетесь опытным текстовым программистом, в следующей статье будут рассмотрены основные функции пользовательского интерфейса (UI) VEXcode Pro V5.

Интерфейс VEXcode Pro V5 с обозначенными элементами пользовательского интерфейса, включая меню «Файл», значки на панели инструментов, редактор кода, дерево файлов, панель вывода и мини-карту.

Окна

В интерфейсе Windows программы VEXcode Pro V5 отображается открытое меню «Файл» с опциями: «Создать», «Открыть», «Открыть примеры», «Импорт», «Экспорт» и «Сохранить».

Мак

Интерфейс VEXcode Pro V5 для Mac, отображающий открытое меню «Файл» с опциями: «Создать», «Открыть», «Открыть примеры», «Импорт», «Экспорт» и «Сохранить».

При выборе файла открывается меню «Файл» со следующими опциями:

Окна

В меню «Правка» окна VEXcode Pro V5 отображаются следующие параметры: Отменить, Повторить, Вырезать, Копировать, Вставить, Найти и Заменить.

Мак

В меню «Редактировать» программы VEXcode Pro V5 для Mac отображаются следующие параметры: Отменить, Повторить, Вырезать, Копировать, Вставить, Найти и Заменить.

При выборе «Редактировать» открывается меню «Редактировать» с опциями редактирования.

Окна

В меню «Инструменты» окна VEXcode Pro V5 отображаются такие параметры, как палитра команд, форматирование документа и элементы управления комментариями.

Мак

В меню «Инструменты» VEXcode Pro V5 для Mac отображаются такие параметры, как палитра команд, форматирование документа и элементы управления комментариями.

При выборе «Инструменты» открывается меню «Инструменты» из следующих опций.

  • Свернуть дерево файлов свернет панель дерева файлов, чтобы увеличить область редактирования.

Интерфейс VEXcode Pro V5, демонстрирующий селектор слотов проекта, со слотами с 1 по 8, доступными для скачивания.

Project Slot позволяет пользователям выбрать один из восьми слотов Brain, куда будет загружен проект.

В окне сведений о проекте VEXcode Pro V5 отображаются название проекта, описание и параметры экспертной настройки, включая автозаполнение и конфигурацию робота.

Имя проекта позволяет пользователям присваивать проекту имя для удобства использования.

  • При нажатии на «Имя проекта» откроется «Сведения о проекте», где можно щелкнуть, чтобы включить дополнительные параметры. 
  • Индикатор контроллера будет серым, если контроллер не подключен, оранжевым, если подключен, но нет радиосвязи с мозгом, и зеленым, если подключен к мозгу. 
  • Информация о Brain показывает, подключен ли Robot Brain V5 (зеленый) к пользовательскому интерфейсу, не подключен (серый) или нуждается в обновлении (зеленый мозг с оранжевым предупреждающим треугольником).

На панели инструментов VEXcode Pro V5 отображается расположение кнопки «Загрузить проект» и кнопки «Сборка», когда модуль управления не подключен.

«Загрузить проект — это кнопка, которая появляется при подключении мозга, чтобы пользователи могли загрузить проект в мозг.

Примечание: Когда мозг не подключен, кнопка Download заменяется кнопкойBuild, показанной здесь:

  • «Выполнить позволяет пользователю запустить проект через пользовательский интерфейс после того, как он уже загружен в робот.
  • Stop позволяет пользователю остановить проект через пользовательский интерфейс.
  • Robot Config отображает конфигурацию робота, чтобы пользователи могли добавлять, удалять и изменять устройства, включенные в сборку робота.
  • Справка предоставляет пользователю индивидуальную справку по командам и/или предоставляет справочник команд.
  • Обратная связь позволяет пользователям оценивать свои впечатления от пользовательского интерфейса и напрямую отправлять сообщения VEX.
  • Редактор разделения используется для разделения экрана редактирования, чтобы в пользовательском интерфейсе было две вкладки для просмотра двух разных файлов в проекте или для просмотра разных частей одного и того же файла.
  • Мини-карта показывает пользователям, какая часть исходного файла в данный момент отображается в окне редактора, и позволяет пользователю быстро прокручивать весь файл, перетаскивая выделенный раздел.
  • Дерево файлов предоставляет пользователям список папок и их файлов, которые используются в проекте, чтобы пользователи могли выбрать входной файл, который они хотят редактировать.
  • Свернуть вкладки вывода свернёт вкладки вывода, чтобы увеличить область редактирования.
  • Выходные данные выводят информацию о сохранении, компиляции и сгенерированных ошибках.
  • Проблемы содержит список ошибок, предупреждений и информацию о проблемах. 
  • Терминал отображает текст, напечатанный из пользовательского проекта, работающего в мозге, когда мозг подключен через прямой USB или контроллер. Это также позволяет пользователю отправлять текст в проект, работающий в мозгу, при подключении.
  • Очистить позволяет пользователю удалять сообщения с дисплеев выхода и терминала.  

Статьи по Теме:

For more information, help, and tips, check out the many resources at VEX Professional Development Plus

Last Updated: