Visão geral do VEXcode Pro V5

The VEX Visual Studio Code Extension has replaced VEXcode Pro V5, which is now end-of-life.

VEXcode Blocks and VEXcode Text remain actively developed and supported for all VEX platforms.

VEXcode Pro V5 oferece aos usuários uma experiência de programação autêntica à medida que se tornam programadores mais experientes. Esteja você fazendo a transição de uma linguagem baseada em blocos ou seja um programador experiente baseado em texto, o artigo a seguir cobrirá a funcionalidade principal da interface do usuário (IU) do VEXcode Pro V5.

Interface do VEXcode Pro V5 mostrando elementos da interface do utilizador rotulados, incluindo o menu Ficheiro, ícones da barra de ferramentas, editor de código, árvore de ficheiros, painel de saída e minimapa.

janelas

Interface do VEXcode Pro V5 para Windows mostrando o menu Ficheiro aberto com opções como Novo, Abrir, Abrir exemplos, Importar, Exportar e Guardar.

Mac

Interface do VEXcode Pro V5 para Mac mostrando o menu Ficheiro aberto com opções como Novo, Abrir, Abrir exemplos, Importar, Exportar e Guardar.

Selecionar Arquivo abre o Menu Arquivo com as seguintes opções:

janelas

Menu Editar do VEXcode Pro V5 para Windows, mostrando opções como Desfazer, Refazer, Recortar, Copiar, Colar, Localizar e Substituir.

Mac

Menu Editar do VEXcode Pro V5 para Mac, mostrando opções como Desfazer, Refazer, Recortar, Copiar, Colar, Localizar e Substituir.

Selecionar Editar abre o Menu Editar de opções de edição

janelas

Menu de ferramentas do VEXcode Pro V5 para Windows, apresentando opções como a Palete de Comandos, Formatar Documento e controlos de comentários.

Mac

Menu de ferramentas do VEXcode Pro V5 para Mac, apresentando opções como a Palete de Comandos, Formatar Documento e controlos de comentários.

Selecionar Ferramentas abre o Menu Ferramentas das seguintes opções

  • Recolher Árvore de Ficheiros minimizará o Painel da Árvore de Ficheiros para ampliar a área de edição.

Interface do VEXcode Pro V5 mostrando o seletor de slots de projeto com os slots de 1 a 8 disponíveis para download.

Project Slot permite aos usuários selecionar um dos oito slots no Brain para onde o projeto será baixado.

A janela de detalhes do projeto do VEXcode Pro V5 apresenta o nome do projeto, a descrição e as opções avançadas, incluindo o preenchimento automático e a configuração do robô.

Nome do Projeto permite que os usuários atribuam um nome ao projeto para fácil referência.

  • Clicar no Nome do Projeto abrirá os Detalhes do Projeto, onde você pode clicar para ativar as opções avançadas. 
  • O indicador do controlador ficará cinza se nenhum controlador estiver conectado, laranja se estiver conectado, mas não houver link de rádio com o cérebro, e verde quando conectado ao cérebro. 
  • Brain Information mostra se o V5 Robot Brain está conectado (verde) à UI, não conectado (cinza) ou precisa ser atualizado (cérebro verde com triângulo de advertência laranja).

A barra de ferramentas do VEXcode Pro V5 mostra a localização do botão "Download Project" e do botão "Build" quando não está ligado nenhum módulo.

Baixar Projeto é o botão que aparece quando o cérebro está conectado para que os usuários possam baixar o projeto para o cérebro.

Nota: Quando o cérebro não está conectado, o botão Download é substituído pelo botãoBuildmostrado aqui:

  • Run permite que o usuário inicie o projeto por meio da UI depois que ele já tiver sido baixado para o robô.
  • Stop permite que o usuário interrompa o projeto por meio da UI.
  • Robot Config exibe a configuração do robô para que os usuários possam adicionar, remover e modificar os dispositivos incluídos na construção do robô.
  • Help fornece ao usuário a Ajuda de Comando individual e/ou fornece a Referência de Comando.
  • Feedback permite que os usuários avaliem suas experiências com a IU e enviem mensagens diretamente para VEX.
  • Split Editor é usado para dividir a tela de edição para que a UI tenha duas guias para visualizar dois arquivos diferentes dentro do projeto ou para visualizar diferentes partes do mesmo arquivo.
  • Mini Mapa mostra aos usuários qual parte do arquivo de origem está atualmente exibida na janela do editor e permite ao usuário rolar rapidamente por todo o arquivo arrastando a seção destacada.
  • Árvore de Arquivos fornece aos usuários uma lista de pastas e seus arquivos que são usados ​​no projeto para que os usuários possam selecionar o arquivo de entrada que desejam editar.
  • Recolher guias de saída minimizará as guias de saída para ampliar a área de edição.
  • A saída lista informações sobre salvamento, compilação e erros gerados.
  • Problemas lista erros, avisos e informações sobre problemas. 
  • Terminal exibe texto impresso de um projeto do usuário em execução no cérebro quando o cérebro está conectado via USB direto ou controlador. Ele também permite que o usuário envie texto para o projeto em execução no cérebro quando conectado.
  • Clear permite que o usuário exclua mensagens dos displays Output e Terminal.  

Artigos relacionados:

For more information, help, and tips, check out the many resources at VEX Professional Development Plus

Last Updated: