Przegląd VEXcode Pro V5

The VEX Visual Studio Code Extension has replaced VEXcode Pro V5, which is now end-of-life.

VEXcode Blocks and VEXcode Text remain actively developed and supported for all VEX platforms.

VEXcode Pro V5 zapewnia użytkownikom autentyczne doświadczenie programowania, gdy stają się bardziej doświadczonymi programistami. Niezależnie od tego, czy przechodzisz z języka blokowego, czy jesteś doświadczonym programistą tekstowym, poniższy artykuł omówi główną funkcjonalność interfejsu użytkownika (UI) VEXcode Pro V5.

Interfejs VEXcode Pro V5 pokazujący oznaczone elementy interfejsu użytkownika, w tym menu Plik, ikony paska narzędzi, edytor kodu, drzewo plików, panel wyjściowy i minimapę.

Okna

Interfejs systemu Windows VEXcode Pro V5 pokazujący otwarte menu Plik z opcjami takimi jak Nowy, Otwórz, Otwórz przykłady, Importuj, Eksportuj i Zapisz.

Prochowiec

Interfejs VEXcode Pro V5 na komputerze Mac pokazujący otwarte menu Plik z opcjami takimi jak Nowy, Otwórz, Otwórz przykłady, Importuj, Eksportuj i Zapisz.

Wybranie Plik otwiera Menu Plik z następującymi opcjami:

Okna

Menu Edycja systemu Windows w programie VEXcode Pro V5 zawiera opcje Cofnij, Ponów, Wytnij, Kopiuj, Wklej, Znajdź i Zamień.

Prochowiec

VEXcode Pro V5 Mac Menu edycji zawierające opcje takie jak Cofnij, Ponów, Wytnij, Kopiuj, Wklej, Znajdź i Zamień.

Wybranie opcji Edytuj otwiera Menu edycji z opcjami edycji

Okna

Menu narzędzi systemu Windows w programie VEXcode Pro V5 zawiera opcje takie jak Paleta poleceń, Formatowanie dokumentu i sterowanie komentarzami.

Prochowiec

Menu narzędzi VEXcode Pro V5 Mac zawierające opcje takie jak Paleta poleceń, Formatowanie dokumentu i sterowanie komentarzami.

Wybranie Narzędzia otwiera Menu Narzędzi z następującymi opcjami

  • Zwiń drzewo plików zminimalizuje panel drzewa plików, powiększając obszar edycji.

Interfejs VEXcode Pro V5 przedstawiający selektor gniazd projektu. Dostępne do pobrania są gniazda od 1 do 8.

Project Slot pozwala użytkownikom wybrać jedno z ośmiu gniazd w Brain, do którego projekt zostanie pobrany.

Okno szczegółów projektu VEXcode Pro V5 zawierające nazwę projektu, opis i opcje eksperckie, w tym autouzupełnianie i konfigurację robota.

Nazwa projektu umożliwia użytkownikom przypisanie projektu nazwy w celu łatwego odniesienia.

  • Kliknięcie nazwy projektu spowoduje otwarcie szczegółów projektu, w których możesz kliknąć, aby włączyć opcje eksperckie. 
  • Wskaźnik kontrolera będzie szary, jeśli nie jest podłączony żaden kontroler, pomarańczowy, jeśli jest podłączony, ale nie ma połączenia radiowego z mózgiem, i zielony, jeśli jest podłączony do mózgu. 
  • Informacje o mózgu pokazuje, czy mózg robota V5 jest podłączony (zielony) do interfejsu użytkownika, nie jest podłączony (szary) lub wymaga aktualizacji (zielony mózg z pomarańczowym trójkątem ostrzegawczym).

Pasek narzędzi VEXcode Pro V5 pokazujący położenie przycisków Pobierz projekt i Kompiluj, gdy żaden mózg nie jest podłączony.

Pobierz projekt to przycisk, który pojawia się, gdy mózg jest podłączony, dzięki czemu użytkownicy mogą pobrać projekt do mózgu.

Uwaga: gdy mózg nie jest podłączony, przycisk Pobierz zostaje zastąpiony przyciskiemBuildpokazanym tutaj:

  • Run umożliwia użytkownikowi rozpoczęcie projektu za pośrednictwem interfejsu użytkownika po jego pobraniu do robota.
  • Stop pozwala użytkownikowi zatrzymać projekt poprzez interfejs użytkownika.
  • Robot Config wyświetla konfigurację robota, dzięki czemu użytkownicy mogą dodawać, usuwać i modyfikować urządzenia zawarte w konstrukcji robota.
  • Pomoc zapewnia użytkownikowi indywidualną pomoc dotyczącą poleceń i/lub zapewnia podręcznik poleceń.
  • Opinia pozwala użytkownikom oceniać swoje doświadczenia z interfejsem użytkownika i bezpośrednio wysyłać wiadomości do VEX.
  • Split Editor służy do dzielenia ekranu edycji, dzięki czemu interfejs użytkownika ma dwie zakładki umożliwiające przeglądanie dwóch różnych plików w projekcie lub przeglądanie różnych części tego samego pliku.
  • Mini Mapa pokazuje użytkownikowi, która część pliku źródłowego jest aktualnie wyświetlana w oknie edytora i pozwala użytkownikowi szybko przewijać cały plik poprzez przeciąganie podświetlonej sekcji.
  • File Tree udostępnia użytkownikom listę folderów i ich plików używanych w projekcie, dzięki czemu użytkownicy mogą wybrać plik wejściowy, który chcą edytować.
  • Zwiń zakładki wyjściowe zminimalizuje zakładki wyjściowe, aby powiększyć obszar edycji.
  • Dane wyjściowe zawierają informacje o zapisywaniu, kompilacji i generowanych błędach.
  • Problemy zawiera listę błędów, ostrzeżeń i informacji o problemach. 
  • Terminal wyświetla tekst wydrukowany z projektu użytkownika działającego w mózgu, gdy mózg jest podłączony przez bezpośrednie złącze USB lub kontroler. Umożliwia także użytkownikowi wysyłanie tekstu do projektu działającego w mózgu po podłączeniu.
  • Kasuj pozwala użytkownikowi usunąć komunikaty z wyświetlaczy Wyjście i Terminal.  

Powiązane artykuły:

For more information, help, and tips, check out the many resources at VEX Professional Development Plus

Last Updated: