The VEX Visual Studio Code Extension has replaced VEXcode Pro V5, which is now end-of-life.

VEXcode Blocks and VEXcode Text remain actively developed and supported for all VEX platforms.

VEXcode Pro V5 は、経験豊富なプログラマになるための本格的なプログラミング体験をユーザーに提供します。ブロック ベースの言語から移行する場合でも、経験豊富なテキスト ベース プログラマである場合でも、次の記事では VEXcode Pro V5 ユーザー インターフェイス (UI) の主な機能について説明します。

VEXcode Pro V5のインターフェースには、ファイルメニュー、ツールバーアイコン、コードエディタ、ファイルツリー、出力パネル、ミニマップなど、ラベル付きのUI要素が表示されています。

ウィンドウズ

VEXcode Pro V5のWindowsインターフェースで、ファイルメニューが開いた状態が表示されています。メニューには、「新規作成」、「開く」、「サンプルを開く」、「インポート」、「エクスポート」、「保存」などのオプションが含まれています。

マック

VEXcode Pro V5 Macのインターフェースで、ファイルメニューが開いた状態を示しており、新規作成、開く、サンプルを開く、インポート、エクスポート、保存などのオプションが表示されています。

ファイルを選択すると、次のオプションを含む ファイル メニュー が開きます

ウィンドウズ

VEXcode Pro V5のWindows編集メニューには、元に戻す、やり直し、切り取り、コピー、貼り付け、検索、置換などのオプションが表示されます。

マック

VEXcode Pro V5 Macの編集メニューには、元に戻す、やり直し、切り取り、コピー、貼り付け、検索、置換などのオプションが表示されます。

「編集」を選択すると、編集オプションの 編集メニュー が開きます。

ウィンドウズ

VEXcode Pro V5のWindowsツールメニューには、コマンドパレット、ドキュメントの書式設定、コメントコントロールなどのオプションが表示されています。

マック

VEXcode Pro V5 Mac版のツールメニューには、コマンドパレット、ドキュメントのフォーマット、コメントコントロールなどのオプションが表示されています。

[ツール] を選択すると、次のオプションの ツール メニュー が開きます。

  • ファイルツリーを折りたたむ 、ファイルツリーパネルを最小化して編集領域を拡大します。

VEXcode Pro V5のインターフェースには、ダウンロード可能なスロット1~8が表示されたプロジェクトスロットセレクターが表示されています。

プロジェクト スロット では、ユーザーはプロジェクトのダウンロード先となる Brain 上の 8 つのスロットの 1 つを選択できます。

VEXcode Pro V5のプロジェクト詳細ウィンドウには、プロジェクト名、説明、およびオートコンプリートやロボット構成などのエキスパートオプションが表示されます。

プロジェクト名 、ユーザーは簡単に参照できるようにプロジェクトに名前を割り当てることができます。

  • プロジェクト名をクリックするとプロジェクトの詳細が開き、クリックしてエキスパート オプションを有効にできます。 
  • コントローラーインジケーター は、コントローラーが接続されていない場合は灰色、接続されているが脳への無線リンクがない場合はオレンジ色、脳に接続されている場合は緑色になります。 
  • Brain Information 、V5 Robot Brain が UI に接続されているか (緑)、接続されていないか (灰色)、または更新する必要があるか (オレンジ色の警告三角形が付いた緑のブレイン) を示します。

VEXcode Pro V5のツールバーに、脳が接続されていない状態で「プロジェクトのダウンロード」ボタンと「ビルド」ボタンの位置が表示されます。

Download Project は、Brain が接続されているときに表示されるボタンで、プロジェクトを Brain にダウンロードできます。

注: ブレインが接続されていない場合、ダウンロード ボタンは、ここに示すBuild ボタンに置き換えられます:

  • Run 使用すると、プロジェクトがロボットにダウンロードされた後、ユーザーは UI を通じてプロジェクトを開始できます。
  • Stop 使用すると、ユーザーは UI を通じてプロジェクトを停止できます。
  • Robot Config ロボットの構成が表示され、ユーザーがロボットのビルドに含まれるデバイスを追加、削除、および変更できるようになります。
  • ヘルプ ユーザーに個別のコマンド ヘルプやコマンド リファレンスを提供します。
  • フィードバック では、ユーザーが UI のエクスペリエンスを評価し、VEX に直接メッセージを送信できます。
  • Split Editor は編集画面を分割し、プロジェクト内の 2 つの異なるファイルを表示するため、または同じファイルの異なる部分を表示するために UI に 2 つのタブが表示されるようにするために使用されます。
  • ミニマップ 、ソース ファイルのどの部分がエディタ ウィンドウに現在表示されているかをユーザーに示し、ユーザーは強調表示されたセクションをドラッグすることでファイル全体をすばやくスクロールできます。
  • ファイル ツリー 、プロジェクト内で使用されるフォルダーとそのファイルのリストをユーザーに提供し、ユーザーが編集したい入力ファイルを選択できるようにします。
  • Collapse Output Tabs は、出力タブを最小化し、編集領域を拡大します。
  • 出力 は、保存、コンパイル、および生成されたエラーに関する情報がリストされます。
  • 問題 は、エラー、警告、および問題に関する情報がリストされます。 
  • ターミナル 、ブレインが直接 USB またはコントローラー経由で接続されている場合、ブレイン上で実行されているユーザー プロジェクトから印刷されたテキストを表示します。また、接続時に脳内で実行されているプロジェクトにテキストを送信することもできます。
  • Clear すると、ユーザーは出力画面とターミナル画面からメッセージを削除できます。  

関連記事:

For more information, help, and tips, check out the many resources at VEX Professional Development Plus

Last Updated: