VEXcode V5 4.0 では、さまざまな新機能が導入されています。このメジャーアップデートは、ロボットコーディングの生産性とアクセシビリティの向上に重点を置いています。 VEXcode V5 4.0 で利用できる新機能については、以下をお読みください。

VEXcode V5 4.0 の新しいインストーラーをダウンロードするには、ここをクリックしてください。

スイッチブロック

新しいスイッチ ブロックが利用可能になり、ブロックベースのコーディングからテキストベースのプログラミングへのシームレスな移行が可能になりました。

VEXcode V5では、スイッチブロックがツールボックスからワークスペースにドラッグされる様子が示されています。ユーザーはスイッチブロックを選択し、そこにPythonコマンドを入力し始めます。

ドラッグ アンド ドロップ スイッチ ブロック: すべてのスイッチ ブロックは、ツールボックスからドラッグして直接入力できます。

スイッチブロックはVEXcode V5ワークスペースに表示されます。ユーザーが自動修正機能を使用して、完全なPythonコマンドをブロックに入力しています。コマンドは drivetrain.turn_for(LEFT, 90, DEGREES) と読み取られます。

ブロック プロジェクトに Python を直接入力: VEXcode を使用すると、Python コマンドをプロジェクトに直接組み込んで、他のブロックとシームレスに統合できます。正しいコードの記述を支援するために、VEXcode は Python コマンドの自動補完機能も提供します。

VEXcode V5ワークスペースに、モーションブロックのスタックが表示されます。ユーザーはスタックを右クリックしてコンテキストメニューを開き、「スタックをスイッチブロックに変換」オプションを選択します。 3つのブロックのスタックが、対応する3行のPythonコードを持つ1つのSwitchブロックに変換されます。

コード変換: クリック 1 回でブロック スタック全体を Python に変換します。

この機能は、ブロックからテキストに移行しようとしている学習者に最適です。スイッチブロックを使ったコーディングの詳細については、こちらをご覧ください


WebベースのVEXcodeで保存と読み込み

VEXcode V5ツールバーのプロジェクト名フィールドに、プロジェクトが保存されるたびに更新される保存メッセージが表示される。最初に「保存されていません」と表示され、次に「保存中」、最後に「保存済み」と表示されます。

Web ベースの VEXcode では、プロジェクトが最初に保存されると、プロジェクトの変更が自動的に保存されるようになりました。

ファイル メニューのその他の変更:

  • デバイスからロード が開くに変更されました。
  • デバイスに保存 がを付けて保存に変更されました。
  • また、 保存 ボタンを使用して手動で保存することもできます。

Chrome ブラウザで VEXcode V5 プロジェクトを読み込んで保存する方法のステップバイステップ ガイドについては、こちらをご覧ください。


アップデートされたAIビジョンセンサー検出

AI ビジョン センサーは、AprilTags と AI 分類を検出できるようになりました。

VEXcode V5のAI Vision Utilityメニューに、3つのAprilTagをキャプチャしたカメラのライブフィードが表示されます。 AprilTags機能はオンになっていますが、AI分類機能はオフになっています。認識されたタグには、それぞれのID、座標、寸法がラベル付けされています。

AprilTags は検出可能で、一意の ID を持つ画像です。印刷して現場でロボットに使用することもできます。印刷可能なAprilTag PDFをここからダウンロードしてください。

VEXcode V5 の AI Vision Utility メニュー。メニューには、検出された4つの物体(2つの青いリング、赤いリング、および移動するゴール)を含むライブカメラ映像が表示されます。それぞれの物体には、色、位置、寸法、および信頼度スコアを示す境界ボックスが表示されます。右側のパネルには、AprilTagsとAI分類を有効にするオプションがあり、AI分類モードは「教室要素」に設定されています。

AI 分類モデルには、教育現場でさまざまな色のボール、リング、立方体を検出するために使用できる教室要素と、現在の VEX ロボット競技会 (V5RC) 2024-2025 ハイステークス ゲームのゲーム要素の検出をサポートする競技要素が含まれます。

AI ビジョン センサーを ブロックPythonC 使用する方法については、こちらをご覧ください。


ブロックを声に出して読む

VEXcode V5 4.0 内のすべてのブロックは、右クリックするだけで読み上げられるようになりました。

この機能は Android を除くすべてのデバイスで利用できます。

VEXcode V5のブロック用ドライブが、コンテキストメニューを開いた状態で表示されています。上から順に、複製、ブロック無効化、ブロック削除、ブロックヘルプ、ブロックをスイッチブロックに変換、ブロック読み取りのオプションが表示されます。「ブロックの読み取り」オプションが強調表示されています。

  • カスタマイズ可能な音声: 新しいツール メニューでさまざまな音声から選択し、速度とピッチを調整します。
  • コンテキスト メニューの統合: 任意のブロックを右クリックすると、読み上げが聞こえます。

VEXcode の読み取り機能の使用方法に関する詳細な手順については、こちらをご覧ください。


ツールメニュー

VEXcode V5 4.0 では、[ツール] メニューが [ファイル] メニューからツールバーに移動され、生産性とアクセシビリティのための機能が満載になりました。

VEXcode V5ツールバーの「ツール」ドロップダウンメニューを開いた状態。表示されるオプションは5つで、それぞれ「テーマ」「キーボードショートカット」「音声設定」「VEXcodeサウンドの管理」「APIドキュメント」と表示されます。

キーボードショートカット

ヘルプ ドキュメントの開始、停止、および開くための新しいキーボード ショートカットが利用できます。

マック ウィンドウズ
VEXcode V5 Macツールバーの「ツール」ドロップダウンメニューを開き、「キーボードショートカット」オプションを選択した状態。利用可能なキーボードショートカットは、右側の2つ目のドロップダウンメニューに表示され、「開始」「停止」「ヘルプを開く」という3つのオプションがあります。各オプションには対応するキーボードショートカットキーがあります。開始のホットキーはコマンドキーとリターンキーの組み合わせ、停止のホットキーはコマンドキーとEキーの組み合わせ、ヘルプを開くホットキーはコマンドキーとHキーの組み合わせです。 VEXcode V5のWindowsツールバーで、「ツール」ドロップダウンメニューを開き、「キーボードショートカット」オプションを選択した状態。利用可能なキーボードショートカットは、右側の2つ目のドロップダウンメニューに表示され、「開始」「停止」「ヘルプを開く」という3つのオプションがあります。各オプションには対応するキーボードショートカットキーがあります。開始のホットキーはControlキーとEnterキーの組み合わせ、停止のホットキーはControlキーとEキーの組み合わせ、ヘルプを開くホットキーはControlキーとHキーの組み合わせです。

ハイコントラストテーマ

高コントラスト テーマでは、テキストと背景の区別が明確になり、視力低下、色覚異常、その他の視覚障害を持つユーザーがコンテンツを読みやすくなります。

デフォルト 高コントラスト
VEXcode V5のブロックを使ったプロジェクトで、複数のカテゴリのブロックを使用してデフォルトの配色を紹介しています。 VEXcode V5のブロックを使ったプロジェクトで、複数のカテゴリのブロックを用いて高コントラスト配色を紹介しています。

音声設定

新しい Read Blocks 機能を使用すると、このメニューから、使用する音声、読み上げ速度、ピッチを変更できます。

VEXcode V5の音声設定ウィンドウには、音声を選択するためのドロップダウンメニュー、ピッチと速度を変更するための2つのスライダー、そして現在の音声設定を聞くためのテスト音声ボタンが備わっています。

APIドキュメント

包括的な API ドキュメントにアクセスすることで、VEX V5 ロボットの可能性を最大限に探求し、活用することがこれまで以上に簡単になります。

VEXcode V5 APIドキュメントページ(ドライブPythonコマンド用)。 APIページには、各ブロックコマンドとテキストコマンドの説明、機能、およびサンプルプロジェクトが含まれています。

公式の VEX API リファレンス サイトにアクセスするには、ここをクリックしてください。


Web ベースのワイヤレス プロジェクトのダウンロード

Web ベースの VEXcode V5 は、V5 コントローラーを介して V5 Brain にワイヤレスで接続できるようになりました。

緑色のコントローラーアイコンがハイライト表示されたVEXcode V5ツールバー。

プロジェクトを V5 Brain にワイヤレスでダウンロードする方法については、こちらをご覧ください。

For more information, help, and tips, check out the many resources at VEX Professional Development Plus

Last Updated: