Panoramica di VEXcode Pro V5

The VEX Visual Studio Code Extension has replaced VEXcode Pro V5, which is now end-of-life.

VEXcode Blocks and VEXcode Text remain actively developed and supported for all VEX platforms.

VEXcode Pro V5 offre agli utenti un'autentica esperienza di programmazione man mano che diventano programmatori più esperti. Che tu stia passando da un linguaggio basato su blocchi o che tu sia un programmatore esperto basato su testo, il seguente articolo coprirà le funzionalità principali dell'interfaccia utente (UI) di VEXcode Pro V5.

Interfaccia di VEXcode Pro V5 che mostra gli elementi dell'interfaccia utente etichettati, tra cui il menu File, le icone della barra degli strumenti, l'editor di codice, la struttura ad albero dei file, il pannello di output e la minimappa.

finestre

Interfaccia Windows di VEXcode Pro V5 con menu File aperto e opzioni quali Nuovo, Apri, Apri esempi, Importa, Esporta e Salva.

Mac

Interfaccia di VEXcode Pro V5 per Mac con menu File aperto e opzioni quali Nuovo, Apri, Apri esempi, Importa, Esporta e Salva.

Selezionando File si apre il menu File con le seguenti opzioni:

finestre

Menu Modifica di VEXcode Pro V5 per Windows che mostra le opzioni Annulla, Ripeti, Taglia, Copia, Incolla, Trova e Sostituisci.

Mac

Menu Modifica di VEXcode Pro V5 per Mac che mostra le opzioni Annulla, Ripeti, Taglia, Copia, Incolla, Trova e Sostituisci.

Selezionando Modifica si apre il menu Modifica delle opzioni di modifica

finestre

Il menu Strumenti di Windows di VEXcode Pro V5 mostra opzioni quali Tavolozza dei comandi, Formatta documento e controlli per i commenti.

Mac

Il menu Strumenti di VEXcode Pro V5 per Mac mostra opzioni quali Tavolozza dei comandi, Formatta documento e controlli per i commenti.

Selezionando Strumenti si apre le seguenti opzioni

  • Comprimi struttura file ridurrà a icona il pannello Struttura file per ingrandire l'area di modifica.

Interfaccia di VEXcode Pro V5 che mostra il selettore degli slot di progetto con gli slot da 1 a 8 disponibili per il download.

Project Slot consente agli utenti di selezionare uno degli otto slot sul Brain in cui verrà scaricato il progetto.

Finestra Dettagli progetto di VEXcode Pro V5 che mostra il nome del progetto, la descrizione e le opzioni avanzate, tra cui il completamento automatico e la configurazione del robot.

Nome progetto consente agli utenti di assegnare al progetto un nome per una facile consultazione.

  • Facendo clic su Nome progetto si apriranno i Dettagli progetto dove è possibile fare clic per abilitare le opzioni avanzate. 
  • L'indicatore del controller sarà grigio se nessun controller è collegato, arancione se connesso ma non c'è collegamento radio con il cervello e verde quando connesso al cervello. 
  • Informazioni sul cervello mostra se il cervello del robot V5 è collegato (verde) all'interfaccia utente, non connesso (grigio) o deve essere aggiornato (cervello verde con triangolo di avvertenza arancione).

La barra degli strumenti di VEXcode Pro V5 mostra la posizione del pulsante "Scarica progetto" e del pulsante "Compila" quando non è collegato alcun modulo di controllo.

Scarica progetto è il pulsante che appare quando Brain è connesso in modo che gli utenti possano scaricare il progetto nel Brain.

Nota: quando il cervello non è connesso, il pulsante Download viene sostituito dal pulsanteBuildmostrato qui:

  • Esegui consente all'utente di avviare il progetto tramite l'interfaccia utente dopo che è già stato scaricato sul robot.
  • Interrompi consente all'utente di interrompere il progetto tramite l'interfaccia utente.
  • Robot Config visualizza la configurazione del robot in modo che gli utenti possano aggiungere, rimuovere e modificare i dispositivi inclusi nella build del robot.
  • Aiuto fornisce all'utente un aiuto per i comandi individuale e/o fornisce il riferimento ai comandi.
  • Feedback consente agli utenti di valutare le proprie esperienze con l'interfaccia utente e inviare messaggi direttamente a VEX.
  • Split Editor viene utilizzato per dividere la schermata di modifica in modo che l'interfaccia utente abbia due schede per esaminare due file diversi all'interno del progetto o per esaminare parti diverse dello stesso file.
  • Mini mappa mostra agli utenti quale parte del file sorgente è attualmente visualizzata nella finestra dell'editor e consente all'utente di scorrere rapidamente l'intero file trascinando la sezione evidenziata.
  • File Tree fornisce agli utenti un elenco di cartelle e relativi file utilizzati all'interno del progetto in modo che gli utenti possano selezionare il file di input che desiderano modificare.
  • Comprimi le schede di output ridurrà a icona le schede di output per ingrandire l'area di modifica.
  • L'output elenca le informazioni sul salvataggio, la compilazione e gli errori generati.
  • Problemi elenca errori, avvisi e informazioni sui problemi. 
  • Il terminale visualizza il testo stampato da un progetto utente in esecuzione sul cervello quando il cervello è collegato tramite USB diretta o tramite il controller. Consente inoltre all'utente di inviare testo al progetto in esecuzione nel cervello quando è connesso.
  • Cancella consente all'utente di eliminare i messaggi dai display Output e Terminale.  

Articoli Correlati:

For more information, help, and tips, check out the many resources at VEX Professional Development Plus

Last Updated: