Ikhtisar VEXcode Pro V5

The VEX Visual Studio Code Extension has replaced VEXcode Pro V5, which is now end-of-life.

VEXcode Blocks and VEXcode Text remain actively developed and supported for all VEX platforms.

VEXcode Pro V5 memberi pengguna pengalaman pemrograman autentik saat mereka menjadi programmer yang lebih berpengalaman. Apakah Anda beralih dari bahasa berbasis blok atau seorang programmer berbasis teks berpengalaman, artikel berikut akan membahas fungsionalitas utama Antarmuka Pengguna (UI) VEXcode Pro V5.

Antarmuka VEXcode Pro V5 menampilkan elemen UI berlabel termasuk menu File, ikon toolbar, editor kode, pohon file, panel output, dan peta mini.

Jendela

Antarmuka Windows VEXcode Pro V5 menampilkan menu File yang terbuka dengan opsi termasuk Baru, Buka, Buka Contoh, Impor, Ekspor, dan Simpan.

Mac

Antarmuka VEXcode Pro V5 untuk Mac menampilkan menu File yang terbuka dengan pilihan termasuk Baru, Buka, Buka Contoh, Impor, Ekspor, dan Simpan.

Memilih File akan membuka Menu File dengan pilihan berikut:

Jendela

Menu Edit Windows VEXcode Pro V5 menampilkan opsi termasuk Undo, Redo, Cut, Copy, Paste, Find, dan Replace.

Mac

Menu Edit VEXcode Pro V5 Mac menampilkan opsi termasuk Undo, Redo, Cut, Copy, Paste, Find, dan Replace.

Memilih Edit akan membuka Menu Edit dari pilihan pengeditan

Jendela

Menu VEXcode Pro V5 Windows Tools menampilkan opsi termasuk Command Palette, Format Document, dan kontrol komentar.

Mac

Menu Tools VEXcode Pro V5 Mac menampilkan opsi termasuk Command Palette, Format Document, dan kontrol komentar.

Memilih Alat akan membuka Menu Alat dari opsi berikut

  • Collapse File Tree akan memperkecil Panel Pohon File untuk memperbesar area pengeditan.

Antarmuka VEXcode Pro V5 menampilkan pemilih slot proyek dengan slot 1 hingga 8 yang tersedia untuk diunduh.

Slot Proyek memungkinkan pengguna untuk memilih salah satu dari delapan slot di Brain tempat proyek akan diunduh.

Jendela Detail Proyek VEXcode Pro V5 menampilkan nama proyek, deskripsi, dan opsi ahli termasuk pelengkapan otomatis dan konfigurasi robot.

Nama Proyek memungkinkan pengguna menetapkan nama proyek untuk referensi mudah.

  • Mengklik Nama Proyek akan membuka Rincian Proyek tempat Anda dapat mengklik untuk mengaktifkan opsi pakar. 
  • Indikator Pengontrol akan berwarna abu-abu jika tidak ada pengontrol yang terhubung, oranye jika terhubung tetapi tidak ada tautan radio ke otak, dan hijau saat terhubung ke otak. 
  • Informasi Otak menunjukkan apakah Otak Robot V5 terhubung (hijau) ke UI, tidak terhubung (abu-abu), atau perlu diperbarui (otak hijau dengan segitiga peringatan oranye).

Toolbar VEXcode Pro V5 menunjukkan lokasi tombol Unduh Proyek dan tombol Buat saat tidak ada brain yang terhubung.

Unduh Proyek adalah tombol yang muncul saat otak terhubung sehingga pengguna dapat mengunduh proyek ke otak.

Catatan: Ketika otak tidak terhubung, tombol Unduh digantikan oleh tombolByang ditunjukkan di sini:

  • Jalankan memungkinkan pengguna untuk memulai proyek melalui UI setelah diunduh ke robot.
  • Berhenti memungkinkan pengguna untuk menghentikan proyek melalui UI.
  • Konfigurasi Robot menampilkan konfigurasi robot sehingga pengguna dapat menambahkan, menghapus, dan memodifikasi perangkat yang disertakan dalam pembuatan robot.
  • Bantuan menyediakan pengguna dengan Bantuan Perintah individual dan/atau menyediakan Referensi Perintah.
  • Umpan Balik memungkinkan pengguna menilai pengalaman mereka dengan UI dan mengirim pesan VEX secara langsung.
  • Split Editor digunakan untuk membagi layar pengeditan sehingga UI memiliki dua tab untuk melihat dua file berbeda dalam proyek, atau untuk melihat bagian berbeda dari file yang sama.
  • Peta Mini menunjukkan kepada pengguna bagian mana dari file sumber yang saat ini ditampilkan di jendela editor dan memungkinkan pengguna untuk menggulir seluruh file dengan cepat dengan menyeret bagian yang disorot.
  • File Tree memberi pengguna daftar folder dan file yang digunakan dalam proyek sehingga pengguna dapat memilih file input yang ingin diedit.
  • Ciutkan Tab Output akan memperkecil Tab Output untuk memperbesar area pengeditan.
  • Output mencantumkan informasi tentang penyimpanan, kompilasi, dan kesalahan yang dihasilkan.
  • Masalah mencantumkan kesalahan, peringatan, dan informasi tentang masalah. 
  • Terminal menampilkan teks yang dicetak dari proyek pengguna yang berjalan di otak saat otak terhubung melalui USB langsung atau pengontrol. Ini juga memungkinkan pengguna untuk mengirim teks ke proyek yang berjalan di otak saat terhubung.
  • Hapus memungkinkan pengguna menghapus pesan dari tampilan Output dan Terminal.  

Artikel terkait:

For more information, help, and tips, check out the many resources at VEX Professional Development Plus

Last Updated: