VEXcode Pro V5 áttekintése

The VEX Visual Studio Code Extension has replaced VEXcode Pro V5, which is now end-of-life.

VEXcode Blocks and VEXcode Text remain actively developed and supported for all VEX platforms.

A VEXcode Pro V5 hiteles programozási élményt nyújt a felhasználóknak, ahogy egyre tapasztaltabb programozókká válnak. Akár blokkalapú nyelvről vált át, akár tapasztalt szöveges programozó, a következő cikk a VEXcode Pro V5 felhasználói felület (UI) fő funkcióit tárgyalja.

A VEXcode Pro V5 felülete feliratozott felhasználói felület elemeket jelenít meg, beleértve a Fájl menüt, az eszköztár ikonjait, a kódszerkesztőt, a fájlfát, a kimeneti panelt és a mini térképet.

ablakok

A VEXcode Pro V5 Windows felülete a megnyitott Fájl menüt mutatja, amelyben többek között az Új, Megnyitás, Példák megnyitása, Importálás, Exportálás és Mentés opciók láthatók.

Mac

A VEXcode Pro V5 Mac felülete a megnyitott Fájl menüt mutatja, amelyben többek között az Új, Megnyitás, Példák megnyitása, Importálás, Exportálás és Mentés opciók láthatók.

A Fájl kiválasztásával megnyílik a Fájl menü a következő lehetőségekkel:

ablakok

VEXcode Pro V5 Windows Szerkesztés menü, amelyen többek között a Visszavonás, Újra, Kivágás, Másolás, Beillesztés, Keresés és Csere opciók láthatók.

Mac

VEXcode Pro V5 Mac Szerkesztés menü, amelyen többek között a Visszavonás, Újra, Kivágás, Másolás, Beillesztés, Keresés és Csere opciók láthatók.

A Szerkesztés kiválasztásával megnyílik a Szerkesztés menü a szerkesztési lehetőségek közül

ablakok

A VEXcode Pro V5 Windows Eszközök menüje olyan opciókat jelenít meg, mint a Parancspaletta, Dokumentum formázása és megjegyzésvezérlők.

Mac

A VEXcode Pro V5 Mac eszközeinek menüje olyan opciókat jelenít meg, mint a Parancspaletta, Dokumentum formázása és megjegyzésvezérlők.

Az Eszközök kiválasztásával megnyílik a Eszközök menü a következő lehetőségek közül

  • A Fájlfa összecsukása lehetőséggel minimalizálhatja a Fájlfa panelt a szerkesztési terület nagyításához.

A VEXcode Pro V5 felülete egy projekthely-választót mutat, amelyen az 1–8. hely letölthető.

A Project Slot lehetővé teszi a felhasználók számára, hogy kiválasszák az agy nyolc helyének egyikét, ahová a projektet letölteni fogják.

A VEXcode Pro V5 Projekt részletei ablakban látható a projekt neve, leírása és szakértői beállításai, beleértve az automatikus kiegészítést és a robot konfigurációját.

A Project Name lehetővé teszi a felhasználók számára, hogy nevet rendeljenek a projekthez az egyszerű hivatkozás érdekében.

  • A Projekt nevére kattintva megnyílik a Projekt részletei, amelyre kattintva engedélyezheti a szakértői beállításokat. 
  • A vezérlőjelző szürke, ha nincs vezérlő csatlakoztatva, narancssárga, ha csatlakoztatva van, de nincs rádiókapcsolat az agyhoz, és zöld, ha az agyhoz csatlakozik. 
  • Brain Information megmutatja, hogy a V5 Robot Brain csatlakozik-e (zöld) a felhasználói felülethez, nincs-e csatlakoztatva (szürke), vagy frissítésre szorul (zöld agy narancssárga figyelmeztető háromszöggel).

A VEXcode Pro V5 eszköztára, amelyen látható a Projekt letöltése gomb és a Építés gomb helye, amikor nincs agy csatlakoztatva.

A Project letöltése az a gomb, amely akkor jelenik meg, amikor az agy csatlakoztatva van, így a felhasználók letölthetik a projektet az agyba.

Megjegyzés: Ha az agy nincs csatlakoztatva, a Letöltés gombot az itt láthatóBuild gombváltja fel:

  • Futtatás lehetővé teszi a felhasználó számára, hogy elindítsa a projektet a felhasználói felületen keresztül, miután az már letöltődött a robotra.
  • Stop lehetővé teszi a felhasználó számára a projekt leállítását a felhasználói felületen keresztül.
  • Robot Config megjeleníti a robot konfigurációját, így a felhasználók hozzáadhatják, eltávolíthatják és módosíthatják a robot összeállításában szereplő eszközöket.
  • Súgó egyéni parancssúgót biztosít a felhasználónak és/vagy a parancsreferenciát.
  • Visszajelzés lehetővé teszi a felhasználók számára, hogy értékeljék a felhasználói felülettel kapcsolatos tapasztalataikat, és közvetlenül küldjenek VEX üzenetet.
  • Split Editor a szerkesztőképernyő felosztására szolgál, így a felhasználói felületen két fül található a projekten belüli két különböző fájl vagy ugyanannak a fájlnak a különböző részeinek megtekintéséhez.
  • Mini Map megmutatja a felhasználóknak, hogy a forrásfájl mely része jelenik meg pillanatnyilag a szerkesztőablakban, és lehetővé teszi a felhasználó számára, hogy a kiemelt rész húzásával gyorsan görgessen a teljes fájlon.
  • Fájlfa a felhasználók számára a projektben használt mappák és fájljaik listáját nyújtja, így a felhasználók kiválaszthatják a szerkeszteni kívánt bemeneti fájlt.
  • A Kimeneti lapok összecsukása A szerkesztési terület nagyításához kicsinyíti a kimeneti füleket.
  • Az kimenet a mentéssel, fordítással és a generált hibákkal kapcsolatos információkat listázza ki.
  • Problémák felsorolja a hibákat, a figyelmeztetéseket és a problémákkal kapcsolatos információkat. 
  • Az terminál az agyon futó felhasználói projektből kinyomtatott szöveget jeleníti meg, ha az agy közvetlen USB-n vagy a vezérlőn keresztül csatlakozik. Azt is lehetővé teszi a felhasználó számára, hogy szöveget küldjön az agyon futó projektnek, amikor csatlakoztatva van.
  • Clear lehetővé teszi, hogy a felhasználó törölje az üzeneteket a kimenet és a terminál képernyőről.  

Kapcsolódó cikkek:

For more information, help, and tips, check out the many resources at VEX Professional Development Plus

Last Updated: