Présentation de VEXcode Pro V5

The VEX Visual Studio Code Extension has replaced VEXcode Pro V5, which is now end-of-life.

VEXcode Blocks and VEXcode Text remain actively developed and supported for all VEX platforms.

VEXcode Pro V5 offre aux utilisateurs une expérience de programmation authentique à mesure qu'ils deviennent des programmeurs plus expérimentés. Que vous passiez d'un langage basé sur des blocs ou que vous soyez un programmeur texte expérimenté, l'article suivant couvrira les principales fonctionnalités de l'interface utilisateur (UI) de VEXcode Pro V5.

Interface de VEXcode Pro V5 montrant les éléments d'interface utilisateur étiquetés, notamment le menu Fichier, les icônes de la barre d'outils, l'éditeur de code, l'arborescence des fichiers, le panneau de sortie et la mini-carte.

les fenêtres

Interface Windows de VEXcode Pro V5 montrant le menu Fichier ouvert avec des options telles que Nouveau, Ouvrir, Ouvrir des exemples, Importer, Exporter et Enregistrer.

Mac

Interface VEXcode Pro V5 pour Mac montrant le menu Fichier ouvert avec les options suivantes : Nouveau, Ouvrir, Ouvrir des exemples, Importer, Exporter et Enregistrer.

La sélection de Fichier ouvre le Menu Fichier avec les options suivantes :

les fenêtres

Menu Édition de VEXcode Pro V5 pour Windows affichant les options suivantes : Annuler, Rétablir, Couper, Copier, Coller, Rechercher et Remplacer.

Mac

Menu Édition de VEXcode Pro V5 pour Mac affichant les options suivantes : Annuler, Rétablir, Couper, Copier, Coller, Rechercher et Remplacer.

La sélection de Modifier ouvre le menu Édition des options d'édition

les fenêtres

Menu Outils Windows de VEXcode Pro V5 affichant des options telles que la palette de commandes, le formatage du document et les contrôles de commentaires.

Mac

Menu Outils de VEXcode Pro V5 pour Mac affichant des options telles que la palette de commandes, le formatage du document et les commandes de commentaires.

La sélection d'Outils ouvre le menu Outils des options suivantes

  • Réduire l'arborescence des fichiers réduira le panneau de l'arborescence des fichiers pour agrandir la zone d'édition.

Interface VEXcode Pro V5 affichant le sélecteur d'emplacement de projet avec les emplacements 1 à 8 disponibles au téléchargement.

Project Slot permet aux utilisateurs de sélectionner l'un des huit emplacements du cerveau où le projet sera téléchargé.

Fenêtre Détails du projet VEXcode Pro V5 affichant le nom du projet, sa description et les options avancées, notamment la saisie semi-automatique et la configuration du robot.

Nom du projet permet aux utilisateurs d'attribuer un nom au projet pour faciliter la référence.

  • En cliquant sur Nom du projet, vous ouvrirez les détails du projet sur lesquels vous pourrez cliquer pour activer les options expertes. 
  • L'indicateur du contrôleur sera gris si aucun contrôleur n'est connecté, orange s'il est connecté mais il n'y a pas de liaison radio avec le cerveau, et vert lorsqu'il est connecté au cerveau. 
  • Brain Information indique si le V5 Robot Brain est connecté (vert) à l'interface utilisateur, s'il n'est pas connecté (gris) ou doit être mis à jour (cerveau vert avec triangle d'avertissement orange).

La barre d'outils VEXcode Pro V5 affiche l'emplacement du bouton Télécharger le projet et du bouton Compiler lorsqu'aucun cerveau n'est connecté.

Télécharger le projet est le bouton qui apparaît lorsque le cerveau est connecté afin que les utilisateurs puissent télécharger le projet sur le cerveau.

Remarque : Lorsque le cerveau n'est pas connecté, le bouton Télécharger est remplacé par le boutonBBuildillustré ici :

  • Run permet à l'utilisateur de démarrer le projet via l'interface utilisateur une fois qu'il a déjà été téléchargé sur le robot.
  • Stop permet à l'utilisateur d'arrêter le projet via l'interface utilisateur.
  • Robot Config affiche la configuration du robot afin que les utilisateurs puissent ajouter, supprimer et modifier les appareils inclus dans la construction du robot.
  • Aide fournit à l'utilisateur une aide sur les commandes individuelles et/ou fournit la référence des commandes.
  • Feedback permet aux utilisateurs d'évaluer leurs expériences avec l'interface utilisateur et d'envoyer un message directement à VEX.
  • Split Editor est utilisé pour diviser l'écran d'édition afin que l'interface utilisateur comporte deux onglets pour examiner deux fichiers différents au sein du projet, ou pour examiner différentes parties du même fichier.
  • Mini Map montre aux utilisateurs quelle partie du fichier source est actuellement affichée dans la fenêtre de l'éditeur et permet à l'utilisateur de faire défiler rapidement l'ensemble du fichier en faisant glisser la section en surbrillance.
  • L'arborescence de fichiers fournit aux utilisateurs une liste de dossiers et de leurs fichiers utilisés dans le projet afin que les utilisateurs puissent sélectionner le fichier d'entrée qu'ils souhaitent modifier.
  • Réduire les onglets de sortie réduira les onglets de sortie pour agrandir la zone d'édition.
  • La sortie répertorie les informations sur l'enregistrement, la compilation et les erreurs générées.
  • Problèmes répertorie les erreurs, les avertissements et les informations sur les problèmes. 
  • Le terminal affiche le texte imprimé à partir d'un projet utilisateur exécuté sur le cerveau lorsque le cerveau est connecté via USB direct ou le contrôleur. Il permet également à l'utilisateur d'envoyer du texte au projet exécuté sur le cerveau lorsqu'il est connecté.
  • Effacer permet à l'utilisateur de supprimer les messages des écrans Sortie et Terminal.  

Articles Liés:

For more information, help, and tips, check out the many resources at VEX Professional Development Plus

Last Updated: