Nouvelles fonctionnalités de VEXcode V5 4.0

VEXcode V5 4.0 introduit une gamme de nouvelles fonctionnalités. Cette mise à jour majeure se concentre sur l’amélioration de la productivité et de l’accessibilité dans le codage robotique. Lisez ci-dessous pour découvrir quelles nouvelles fonctionnalités sont disponibles avec VEXcode V5 4.0 !

Cliquez ici pour télécharger le nouveau programme d'installation de VEXcode V5 4.0 !

Blocs de commutation

De nouveaux blocs de commutation sont désormais disponibles, rendant la transition du codage par blocs à la programmation textuelle transparente.

Le bloc Switch est illustré dans VEXcode V5 lorsqu'il est glissé hors de la boîte à outils vers l'espace de travail. L'utilisateur sélectionne le bloc Switch et commence à y saisir une commande Python.

Blocs de commutation par glisser-déposer : Tous les blocs de commutation peuvent être glissés depuis la boîte à outils et saisis directement.

Le bloc Switch est affiché dans l'espace de travail VEXcode V5. Un utilisateur utilise la fonction de correction automatique pour saisir une commande Python complète dans le bloc. La commande se lit drivetrain.turn_for(LEFT, 90, DEGREES).

Tapez Python directement dans les projets de blocs : VEXcode vous permet d'intégrer des commandes Python directement dans vos projets, en les intégrant de manière transparente avec d'autres blocs. Pour vous aider à écrire du code correct, VEXcode fournit également une fonction de saisie semi-automatique pour les commandes Python.

Une pile de blocs Motion est affichée dans l'espace de travail VEXcode V5. L'utilisateur clique avec le bouton droit sur la pile pour ouvrir son menu contextuel, puis sélectionne l'option Convertir la pile en bloc de commutation. La pile de trois blocs se convertit en un seul bloc Switch avec trois lignes de code Python correspondantes.

Conversion de code : Convertissez des piles de blocs entières en Python en un seul clic.

Cette fonctionnalité est parfaite pour les apprenants qui cherchent à passer des blocs au texte. Pour plus d'informations sur le codage avec Switch Blocks, cliquez ici.


Enregistrer et charger dans VEXcode basé sur le Web

Champ Nom du projet dans la barre d'outils VEXcode V5 avec un message d'enregistrement qui se met à jour au fur et à mesure que le projet est enregistré. Le message affiche d'abord « Non enregistré », puis « Enregistrement », et enfin « Enregistré ».

VEXcode basé sur le Web enregistrera désormais automatiquement les modifications apportées au projet une fois que votre projet aura été initialement enregistré.

Autres modifications apportées au menu Fichier :

  • Charger depuis votre Appareil a maintenant été changé enOuvrir.
  • Enregistrer sur votre appareil a maintenant été modifié enEnregistrer sous.
  • Vous pouvez également désormais enregistrer manuellement à l'aide du bouton Enregistrer.

Pour un guide étape par étape sur la façon de charger et d'enregistrer le projet VEXcode V5 sur un navigateur Chrome, cliquez ici.


Détection du capteur de vision AI mise à jour

Le capteur de vision AI est désormais capable de détecter les AprilTags et les classifications AI.

Menu AI Vision Utility dans VEXcode V5, affichant le flux en direct de la caméra capturant trois AprilTags. La fonction AprilTags est activée, tandis que la classification par IA est désactivée. Les balises reconnues sont étiquetées avec leurs identifiants, coordonnées et dimensions respectifs.

Les AprilTags sont des images qui peuvent être détectées et qui ont des identifiants uniques. Ils peuvent être imprimés et utilisés sur le terrain avec des robots. Téléchargez ici un PDF imprimable d'AprilTag.

Menu utilitaire AI Vision dans VEXcode V5. Le menu affiche un flux vidéo en direct de la caméra avec quatre objets détectés : deux anneaux bleus, un anneau rouge et un objectif mobile, chacun avec des cadres de délimitation affichant leurs couleurs, positions, dimensions et scores de confiance. Le panneau de droite propose des options pour activer AprilTags et la classification par IA, le mode de classification par IA étant réglé sur Éléments de classe.

Les modèles de classification de l'IA incluent des éléments de classe, qui peuvent être utilisés dans des contextes éducatifs pour détecter des balles, des anneaux et des cubes de différentes couleurs, ainsi que des éléments de compétition, qui prennent en charge la détection d'éléments de jeu dans le jeu actuel VEX Robotics Competition (V5RC) 2024-2025 High Stakes.

Cliquez ici pour découvrir comment utiliser le capteur de vision AI dans blocs, Pythonet C++.


Lire les blocs à voix haute

Tous les blocs de VEXcode V5 4.0 peuvent désormais être lus à haute voix avec un simple clic droit.

Cette fonctionnalité est disponible sur tous les appareils sauf Android.

Le lecteur VEXcode V5 pour bloc est affiché avec son menu contextuel ouvert. Les options, de haut en bas, sont : Dupliquer, Désactiver le bloc, Supprimer les blocs, Aide sur les blocs, Convertir le bloc en bloc commuté et Lire le bloc. L'option « Lire le bloc » est mise en surbrillance.

  • Voix personnalisables : Choisissez parmi différentes voix et ajustez la vitesse et la hauteur dans le nouveau menu Outils.
  • Intégration du menu contextuel : Cliquez avec le bouton droit sur n’importe quel bloc pour l’entendre lu à haute voix.

Cliquez ici pour obtenir des instructions étape par étape sur la façon d'utiliser la fonction de lecture dans VEXcode.


Menu Outils

VEXcode V5 4.0 a déplacé le menu Outils du menu Fichier vers la barre d'outils, et il est désormais doté de fonctionnalités pour la productivité et l'accessibilité.

Barre d'outils VEXcode V5 avec le menu déroulant Outils ouvert. Cinq options sont affichées : Thème, Raccourcis clavier, Paramètres vocaux, Gérer les sons VEXcode et Documentation API.

Raccourcis clavier

De nouveaux raccourcis clavier sont disponibles pour démarrer, arrêter et ouvrir la documentation d'aide.

Mac Fenêtres
Barre d'outils VEXcode V5 pour Mac avec le menu déroulant Outils ouvert et l'option Raccourcis clavier sélectionnée. Les raccourcis clavier disponibles sont affichés dans un deuxième menu déroulant à droite, avec 3 options : Démarrer, Arrêter et Ouvrir l’aide. Chaque option possède un raccourci clavier correspondant. La touche de raccourci pour démarrer est la touche Commande associée à la touche Entrée, la touche de raccourci pour arrêter est la touche Commande associée à la touche E, et la touche de raccourci pour ouvrir l'aide est la touche Commande associée à la touche H. Barre d'outils VEXcode V5 pour Windows avec le menu déroulant Outils ouvert et l'option Raccourcis clavier sélectionnée. Les raccourcis clavier disponibles sont affichés dans un deuxième menu déroulant à droite, avec 3 options : Démarrer, Arrêter et Ouvrir l’aide. Chaque option possède un raccourci clavier correspondant. Le raccourci clavier pour démarrer est la touche Ctrl + la touche Entrée, le raccourci clavier pour arrêter est la touche Ctrl + la touche E, et le raccourci clavier pour ouvrir l'aide est la touche Ctrl + la touche H.

Thème à contraste élevé

Les thèmes à contraste élevé augmentent la distinction entre le texte et l'arrière-plan, rendant le contenu plus facile à lire pour les utilisateurs malvoyants, daltoniens ou ayant d'autres déficiences visuelles.

Défaut Contraste élevé
Projet de blocs VEXcode V5 avec des blocs de plusieurs catégories pour illustrer le schéma de couleurs par défaut. Projet de blocs VEXcode V5 utilisant des blocs de plusieurs catégories pour illustrer le schéma de couleurs à contraste élevé.

Paramètres de la parole

En utilisant la nouvelle fonctionnalité Lire les blocs, vous pouvez modifier la voix utilisée, la vitesse de parole et la hauteur à partir de ce menu.

Fenêtre des paramètres vocaux de VEXcode V5 avec un menu déroulant pour choisir la voix, deux curseurs pour modifier la hauteur et la vitesse, et enfin un bouton Tester la voix pour écouter les paramètres vocaux actuels.

Documentation de l'API

Accédez à une documentation API complète, ce qui facilite plus que jamais l'exploration et l'utilisation de tout le potentiel de votre robot VEX V5.

Page de documentation de l'API VEXcode V5 pour la commande Python de pilotage. Les pages API incluent des explications, des fonctionnalités et des exemples de projets pour chaque bloc et commande de texte.

Cliquez ici pour accéder au site officiel de référence de l'API VEX.


Téléchargements de projets sans fil basés sur le Web

VEXcode V5 basé sur le Web est désormais capable de se connecter sans fil à un cerveau V5 via un contrôleur V5.

Barre d'outils VEXcode V5 avec une icône de contrôleur verte mise en évidence.

Pour savoir comment télécharger sans fil un projet sur votre V5 Brain, cliquez ici.

For more information, help, and tips, check out the many resources at VEX Professional Development Plus

Last Updated: