VEXcode Pro V5 Yleiskatsaus

The VEX Visual Studio Code Extension has replaced VEXcode Pro V5, which is now end-of-life.

VEXcode Blocks and VEXcode Text remain actively developed and supported for all VEX platforms.

VEXcode Pro V5 tarjoaa käyttäjille aidon ohjelmointikokemuksen, kun heistä tulee kokeneempia ohjelmoijia. Olitpa siirtymässä lohkopohjaisesta kielestä tai oletko kokenut tekstipohjainen ohjelmoija, seuraava artikkeli kattaa VEXcode Pro V5 -käyttöliittymän (UI) päätoiminnot.

VEXcode Pro V5 -käyttöliittymä, jossa näkyy merkityt käyttöliittymäelementit, kuten Tiedosto-valikko, työkalupalkin kuvakkeet, koodieditori, tiedostopuu, tulostuspaneeli ja minikartta.

Windows

VEXcode Pro V5:n Windows-käyttöliittymä, jossa näkyy avoinna Tiedosto-valikko ja vaihtoehdot, kuten Uusi, Avaa, Avaa esimerkkejä, Tuo, Vie ja Tallenna.

Mac

VEXcode Pro V5 Mac -käyttöliittymä, jossa näkyy avoinna oleva Tiedosto-valikko ja vaihtoehdot, kuten Uusi, Avaa, Avaa esimerkkejä, Tuo, Vie ja Tallenna.

Tiedoston valitseminen avaa Tiedosto-valikon seuraavilla vaihtoehdoilla:

Windows

VEXcode Pro V5 Windowsin Muokkaa-valikko, jossa näkyy vaihtoehdot, kuten Kumoa, Tee uudelleen, Leikkaa, Kopioi, Liitä, Etsi ja Korvaa.

Mac

VEXcode Pro V5 Macin Muokkaa-valikko, jossa näkyvät vaihtoehdot, kuten Kumoa, Tee uudelleen, Leikkaa, Kopioi, Liitä, Etsi ja Korvaa.

Kun valitset Muokkaa, muokkausvaihtoehtojen Muokkaa-valikko avautuu

Windows

VEXcode Pro V5:n Windows-työkaluvalikko, jossa näkyy asetuksia, kuten komentopaletti, asiakirjan muotoilu ja kommenttisäätimet.

Mac

VEXcode Pro V5 Macin työkaluvalikko, jossa näkyy asetuksia, kuten komentopaletti, asiakirjan muotoilu ja kommenttisäätimet.

Valitsemalla Työkalut avaa Työkalut-valikon seuraavista vaihtoehdoista

  • Pienennä tiedostopuuta pienentää tiedostopuupaneelin muokkausalueen suurentamiseksi.

VEXcode Pro V5 -käyttöliittymä, jossa näkyy projektipaikan valitsin ja ladattavissa olevat paikat 1–8.

Projektipaikka antaa käyttäjille mahdollisuuden valita yhden kahdeksasta Brain-paikasta, johon projekti ladataan.

VEXcode Pro V5 -projektin tiedot -ikkuna, jossa näkyy projektin nimi, kuvaus ja asiantuntija-asetukset, mukaan lukien automaattinen täydennys ja robotin kokoonpano.

Projektin nimi antaa käyttäjille mahdollisuuden antaa projektille nimen helppokäyttöisyyttä varten.

  • Projektin nimen napsauttaminen avaa Projektin tiedot, josta voit napsauttaa ottaaksesi asiantuntijavaihtoehdot käyttöön. 
  • Ohjaimen ilmaisin on harmaa, jos säädintä ei ole kytketty, oranssi, jos se on kytketty, mutta radiolinkkiä ei ole aivoihin, ja vihreä, kun se on kytketty aivoihin. 
  • Brain Information näyttää, onko V5 Robot Brain kytketty (vihreä) käyttöliittymään, ei kytketty (harmaa) vai onko se päivitettävä (vihreä aivot oranssilla varoituskolmiolla).

VEXcode Pro V5 -työkalurivi, jossa näkyy Lataa projekti -painikkeen ja Rakenna-painikkeen sijainti, kun aivoja ei ole kytketty.

Lataa projekti on painike, joka tulee näkyviin, kun aivot on yhdistetty, jotta käyttäjät voivat ladata projektin aivoihin.

Huomautus: Kun aivot eivät ole yhteydessä, latauspainike korvataan tässä näkyvälläBuild-painikkeella:

  • Run sallii käyttäjän käynnistää projektin käyttöliittymän kautta sen jälkeen, kun se on jo ladattu robottiin.
  • Stop sallii käyttäjän pysäyttää projektin käyttöliittymän kautta.
  • Robot Config näyttää robotin kokoonpanon, jotta käyttäjät voivat lisätä, poistaa ja muokata robotin rakennelmaan sisältyviä laitteita.
  • Ohje tarjoaa käyttäjälle yksittäisen komento-ohjeen ja/tai komentoviitteen.
  • Palaute antaa käyttäjien arvioida kokemuksiaan käyttöliittymästä ja lähettää VEX-viestin suoraan.
  • Split Editor -toimintoa käytetään muokkausnäytön jakamiseen siten, että käyttöliittymässä on kaksi välilehteä, joilla voit tarkastella kahta eri tiedostoa projektin sisällä tai tarkastella saman tiedoston eri osia.
  • Mini Map näyttää käyttäjille, mikä osa lähdetiedostosta on tällä hetkellä näkyvissä muokkausikkunassa ja antaa käyttäjän selata nopeasti koko tiedostoa vetämällä korostettua osaa.
  • Tiedostopuu tarjoaa käyttäjille luettelon kansioista ja niiden tiedostoista, joita käytetään projektissa, jotta käyttäjät voivat valita syöttötiedoston, jota he haluavat muokata.
  • Kutista tulostusvälilehdet pienentää Tulostusvälilehdet muokkausalueen suurentamiseksi.
  • Tulos luettelee tiedot tallentamisesta, kääntämisestä ja luoduista virheistä.
  • Ongelmat luettelee virheet, varoitukset ja tiedot ongelmista. 
  • Liitin näyttää tekstin, joka on tulostettu aivoissa käynnissä olevasta käyttäjäprojektista, kun aivot on kytketty suoraan USB:n tai ohjaimen kautta. Sen avulla käyttäjä voi myös lähettää tekstiä aivoissa käynnissä olevaan projektiin, kun yhteys on muodostettu.
  • Tyhjennä antaa käyttäjän poistaa viestejä lähtö- ja päätenäytöistä.  

Aiheeseen liittyvät artikkelit:

For more information, help, and tips, check out the many resources at VEX Professional Development Plus

Last Updated: