Descripción general de VEXcode Pro V5

The VEX Visual Studio Code Extension has replaced VEXcode Pro V5, which is now end-of-life.

VEXcode Blocks and VEXcode Text remain actively developed and supported for all VEX platforms.

VEXcode Pro V5 brinda a los usuarios una experiencia de programación auténtica a medida que se convierten en programadores más experimentados. Ya sea que esté haciendo la transición de un lenguaje basado en bloques o sea un programador experimentado basado en texto, el siguiente artículo cubrirá la funcionalidad principal de la interfaz de usuario (UI) de VEXcode Pro V5.

Interfaz de VEXcode Pro V5 que muestra los elementos de la interfaz de usuario etiquetados, incluidos el menú Archivo, los iconos de la barra de herramientas, el editor de código, el árbol de archivos, el panel de salida y el minimapa.

ventanas

Interfaz de Windows de VEXcode Pro V5 que muestra el menú Archivo abierto con opciones que incluyen Nuevo, Abrir, Abrir ejemplos, Importar, Exportar y Guardar.

Mac

Interfaz de VEXcode Pro V5 para Mac que muestra el menú Archivo abierto con opciones que incluyen Nuevo, Abrir, Abrir ejemplos, Importar, Exportar y Guardar.

Al seleccionar Archivo se abre el Menú Archivo con las siguientes opciones:

ventanas

Menú Editar de VEXcode Pro V5 para Windows que muestra opciones como Deshacer, Rehacer, Cortar, Copiar, Pegar, Buscar y Reemplazar.

Mac

Menú de edición de VEXcode Pro V5 para Mac que muestra opciones como Deshacer, Rehacer, Cortar, Copiar, Pegar, Buscar y Reemplazar.

Al seleccionar Editar se abre el Menú de edición de opciones de edición.

ventanas

El menú Herramientas de Windows de VEXcode Pro V5 muestra opciones como la paleta de comandos, el formato del documento y los controles de comentarios.

Mac

El menú Herramientas de VEXcode Pro V5 para Mac muestra opciones como la paleta de comandos, el formato del documento y los controles de comentarios.

Al seleccionar Herramientas se abre el Menú Herramientas de las siguientes opciones

  • Collapse File Tree minimizará el panel File Tree para ampliar el área de edición.

Interfaz de VEXcode Pro V5 que muestra el selector de ranuras del proyecto con las ranuras 1 a 8 disponibles para su descarga.

Project Slot permite a los usuarios seleccionar una de las ocho ranuras del Brain donde se descargará el proyecto.

Ventana de detalles del proyecto de VEXcode Pro V5 que muestra el nombre del proyecto, la descripción y las opciones avanzadas, incluyendo la función de autocompletar y la configuración del robot.

Nombre del proyecto permite a los usuarios asignar un nombre al proyecto para facilitar su referencia.

  • Al hacer clic en Nombre del proyecto, se abrirán Detalles del proyecto, donde puede hacer clic para habilitar las opciones de experto. 
  • El indicador del controlador será gris si no hay ningún controlador conectado, naranja si está conectado pero no hay enlace de radio con el cerebro y verde cuando esté conectado al cerebro. 
  • Brain Information muestra si el V5 Robot Brain está conectado (verde) a la interfaz de usuario, no conectado (gris) o necesita ser actualizado (cerebro verde con triángulo de advertencia naranja).

La barra de herramientas de VEXcode Pro V5 muestra la ubicación del botón Descargar proyecto y el botón Construir cuando no hay ningún procesador conectado.

Descargar Proyecto es el botón que aparece cuando el cerebro está conectado para que los usuarios puedan descargar el proyecto al cerebro.

Nota: Cuando el cerebro no está conectado, el botón Descargar se reemplaza por el botónBuildque se muestra aquí:

  • Ejecutar permite al usuario iniciar el proyecto a través de la interfaz de usuario después de que ya se haya descargado en el robot.
  • Detener permite al usuario detener el proyecto a través de la interfaz de usuario.
  • Robot Config muestra la configuración del robot para que los usuarios puedan agregar, eliminar y modificar los dispositivos incluidos en la construcción del robot.
  • Ayuda proporciona al usuario ayuda de comandos individual y/o proporciona la referencia de comandos.
  • Comentarios permite a los usuarios calificar sus experiencias con la interfaz de usuario y enviar mensajes a VEX directamente.
  • Split Editor se utiliza para dividir la pantalla de edición de modo que la interfaz de usuario tenga dos pestañas para ver dos archivos diferentes dentro del proyecto o para ver diferentes partes del mismo archivo.
  • Mini Map muestra a los usuarios qué parte del archivo fuente se muestra actualmente en la ventana del editor y permite al usuario desplazarse rápidamente por todo el archivo arrastrando la sección resaltada.
  • File Tree proporciona a los usuarios una lista de carpetas y sus archivos que se utilizan dentro del proyecto para que los usuarios puedan seleccionar el archivo de entrada que desean editar.
  • Contraer pestañas de salida minimizará las pestañas de salida para ampliar el área de edición.
  • Salida enumera información sobre cómo guardar, compilar y errores generados.
  • Problemas enumera errores, advertencias e información sobre problemas. 
  • Terminal muestra el texto impreso desde un proyecto de usuario que se ejecuta en el cerebro cuando el cerebro está conectado mediante USB directo o el controlador. También permite al usuario enviar texto al proyecto que se ejecuta en el cerebro cuando está conectado.
  • Borrar permite al usuario eliminar mensajes de las pantallas Salida y Terminal.  

Artículos relacionados:

For more information, help, and tips, check out the many resources at VEX Professional Development Plus

Last Updated: