Descripción general de VEXcode Pro V5

The VEX Visual Studio Code Extension has replaced VEXcode Pro V5, which is now end-of-life.

VEXcode Blocks and VEXcode Text remain actively developed and supported for all VEX platforms.

VEXcode Pro V5 proporciona a los usuarios una experiencia de programación auténtica a medida que se convierten en programadores más experimentados. Ya sea que esté pasando de un lenguaje basado en bloques o sea un programador experimentado basado en texto, el siguiente artículo cubrirá la funcionalidad principal de la interfaz de usuario (UI) de VEXcode Pro V5.

Interfaz VEXcode Pro V5 que muestra elementos de interfaz de usuario etiquetados, incluidos el menú Archivo, los iconos de la barra de herramientas, el editor de código, el árbol de archivos, el panel de salida y el mini mapa.

Windows

Interfaz de Windows VEXcode Pro V5 que muestra el menú Archivo abierto con opciones que incluyen Nuevo, Abrir, Abrir ejemplos, Importar, Exportar y Guardar.

Mac

La interfaz de Mac VEXcode Pro V5 muestra el menú Archivo abierto con opciones que incluyen Nuevo, Abrir, Abrir ejemplos, Importar, Exportar y Guardar.

Al seleccionar Archivo, se abre el menú Archivo con las siguientes opciones:

Windows

Menú VEXcode Pro V5 Windows Edit que muestra opciones como Deshacer, Rehacer, Cortar, Copiar, Pegar, Buscar y Reemplazar.

Mac

Menú VEXcode Pro V5 Mac Edit que muestra opciones como Deshacer, Rehacer, Cortar, Copiar, Pegar, Buscar y Reemplazar.

Al seleccionar Editar se abre el menú Editar de opciones de edición

Windows

Menú Herramientas de Windows VEXcode Pro V5 que muestra opciones que incluyen la paleta de comandos, el documento de formato y los controles de comentarios.

Mac

Menú VEXcode Pro V5 Mac Tools que muestra opciones como la paleta de comandos, el documento de formato y los controles de comentarios.

Al seleccionar Herramientas, se abre el menú Herramientas de las siguientes opciones

  • Contraer el árbol de archivos minimizará el panel de árbol de archivos para ampliar el área de edición.

Interfaz VEXcode Pro V5 que muestra el selector de ranuras del proyecto con las ranuras 1 a 8 disponibles para su descarga.

Project Slot permite a los usuarios seleccionar una de las ocho ranuras en el Brain a donde se descargará el proyecto.

Ventana de detalles del proyecto VEXcode Pro V5 que muestra el nombre del proyecto, la descripción y las opciones de expertos, incluida la autocompletar y la configuración del robot.

El nombre del proyecto permite a los usuarios asignar un nombre al proyecto para facilitar su consulta.

  • Al hacer clic en el nombre del proyecto, se abrirán los detalles del proyecto, donde puede hacer clic para habilitar las opciones de expertos. 
  • El indicador del controlador será gris si no hay un controlador conectado, naranja si está conectado pero no hay un enlace de radio al cerebro y verde cuando está conectado al cerebro. 
  • La información del cerebro muestra si el cerebro del robot V5 está conectado (verde) a la interfaz de usuario, no está conectado (gris) o debe actualizarse (cerebro verde con triángulo de advertencia naranja).

Barra de herramientas VEXcode Pro V5 que muestra la ubicación del botón Descargar proyecto y el botón Construir cuando no hay ningún cerebro conectado.

Download Project es el botón que aparece cuando el cerebro está conectado para que los usuarios puedan descargar el proyecto al cerebro.

Nota: Cuando el cerebro no está conectado, el botón Descargar se reemplaza por el botón Edificioque se muestra aquí:

  • La ejecución permite al usuario iniciar el proyecto a través de la interfaz de usuario después de que ya se haya descargado en el robot.
  • Stop permite al usuario detener el proyecto a través de la interfaz de usuario.
  • Robot Config muestra la configuración del robot para que los usuarios puedan agregar, eliminar y modificar los dispositivos incluidos en la construcción del robot.
  • La Ayuda proporciona al usuario Ayuda de Comando individual y/o proporciona la Referencia de Comando.
  • Los comentarios permiten a los usuarios calificar sus experiencias con la interfaz de usuario y el mensaje VEX directamente.
  • Split Editor se utiliza para dividir la pantalla de edición de modo que la interfaz de usuario tenga dos pestañas para ver dos archivos diferentes dentro del proyecto, o para ver diferentes partes del mismo archivo.
  • Mini Map muestra a los usuarios qué parte del archivo de origen se muestra actualmente en la ventana del editor y permite al usuario desplazarse rápidamente por todo el archivo arrastrando la sección resaltada.
  • El árbol de archivos proporciona a los usuarios una lista de carpetas y sus archivos que se utilizan dentro del proyecto para que los usuarios puedan seleccionar el archivo de entrada que desean editar.
  • Contraer las pestañas de salida minimizará las pestañas de salida para ampliar el área de edición.
  • La salida enumera la información sobre el guardado, la compilación y los errores generados.
  • Problemas enumera errores, advertencias e información sobre problemas. 
  • El terminal muestra el texto impreso de un proyecto de usuario que se ejecuta en el cerebro cuando el cerebro está conectado a través de USB directo o el controlador. También permite al usuario enviar texto al proyecto que se ejecuta en el cerebro cuando está conectado.
  • Clear permite al usuario eliminar mensajes de las pantallas Output y Terminal.  

Artículos relacionados:

For more information, help, and tips, check out the many resources at VEX Professional Development Plus

Last Updated: