Wenn Sie Probleme mit Ihrem AI Vision Sensor haben, lesen Sie die folgenden Abschnitte, um die Ursache zu ermitteln und die geeignete Lösung für Ihr spezifisches Problem zu finden.
Problem: AI Vision Sensor stellt keine Verbindung zu VEXcode her
Beim Konfigurieren des AI Vision Sensors in VEXcode wird im Fenster nicht die Ansicht des AI Vision Sensors angezeigt, sondern die Meldung „Kein AI Vision Sensor verbunden“.
Mögliche Ursachen
- Der AI Vision Sensor ist nicht richtig mit dem Computer verbunden.
- Ihr Webbrowser oder VEXcode verfügt nicht über die Kameraberechtigung für den Zugriff auf den AI Vision Sensor.
- Der AI Vision Sensor stellt keine Verbindung zu VEXcode her, während Visual Studio Code geöffnet ist.
Lösungen
Lösung für mögliche Ursache 1
Wenn Ihr AI Vision Sensor nicht richtig mit Ihrem Computer verbunden ist, überprüfen Sie die Kabelverbindung zu Ihrem Computer. Weitere Informationen zum Verbinden Ihres AI Vision Sensors mit Ihrem Computer finden Sie in diesen Artikeln zum Verbinden mit webbasiert und appbasiert VEXcode EXP.
Lösung für mögliche Ursache 2
Wenn Ihr Webbrowser oder VEXcode nicht über Kameraberechtigungen verfügt, kann der AI Vision Sensor keine Verbindung herstellen.
Um dieses Problem zu beheben, lesen Sie die folgenden Artikel:
App-basiert
- Kameraberechtigungen für AI Vision Sensor unter Windows im appbasierten VEXcode EXP zulassen
- Kameraberechtigungen für AI Vision Sensor auf macOS im appbasierten VEXcode EXP zulassen
Webbasiert
Lösung für mögliche Ursache 3
Wenn der AI Vision Sensor an einen Computer angeschlossen wird, auf dem VS Code bereits geöffnet ist, stellt er zunächst automatisch eine Verbindung mit VS Code her. Da der AI Vision Sensor jeweils nur eine Verbindung aufrechterhalten kann, wird eine Verbindung zu VEXcode verhindert. Sie können den AI Vision Sensor in der VEX VS Code-Erweiterung sehen, sobald er eine Verbindung mit VS Code herstellt.
Der AI Vision Sensor wird beim Verbindungsversuch innerhalb des webbasierten VEXcode EXP angezeigt, die Auswahl vonConnect bewirkt jedoch nichts.
Um dieses Problem zu lösen, schließen Sie die VS Code-Anwendung und verbinden Sie Ihren AI Vision Sensor erneut. Wenn Sie den appbasierten VEXcode EXP verwenden, wird der AI Vision Sensor automatisch eine Verbindung hergestellt.
Problem: Der AI Vision Sensor erkennt während Projekten nicht richtig
Mögliche Ursache
In Projekten ist das EXP Brain auf häufige Snapshots aktueller AI Vision Sensor-Daten angewiesen. Ohne regelmäßige Aktualisierungen kann das Gehirn veraltete Informationen verwenden.
Wenn sich ein Roboter oder Objekt zu schnell bewegt, kann es am AI Vision Sensor vorbeikommen, bevor ein neuer Schnappschuss aufgenommen werden kann.
Lösung
Um dieses Problem zu mildern, sollten Sie zwei Ansätze in Betracht ziehen:
Reduzieren Sie die Zeit des Warteblocks, um öfter Schnappschüsse aufzunehmen. Dadurch kann der AI Vision Sensor bei Bewegungen häufiger Daten erfassen.
Reduzieren Sie die Geschwindigkeit des Roboters, damit der AI Vision Sensor während der Bewegung mehr Schnappschüsse machen und so die Menge der erfassten Daten erhöhen kann.
Problem: Vision Utility hat eine falsche Farbe
Mögliche Ursache
Die Sicht des AI Vision Sensors kann verfärbt werden, wenn er bei Anschluss an den Computer durch ein Objekt verdeckt wird oder wenn das AI Vision Utility zu lange geöffnet bleibt.
Lösung
Um dies zu beheben, trennen Sie den AI Vision Sensor von Ihrem Computer und schließen Sie ihn erneut an.
Dadurch wird die Funktion zum automatischen Weißabgleich des AI Vision Sensors ausgelöst, die bei jedem Einschalten des Geräts aktiviert wird.
Problem: Erkennen unbeabsichtigter Objekte im Hintergrund
Mögliche Ursachen
- Der AI Vision Sensor ist nicht auf das Feld ausgerichtet.
- Im Hintergrund befinden sich Objekte, die AI Vision sehen kann.
- Die Farbsignatur ist nicht spezifisch genug und nimmt nahegelegene ähnliche Farben auf.
- Die Beleuchtung im Feld ist uneinheitlich.
Lösungen
Lösung für mögliche Ursache 1
Überprüfen Sie die Montageposition Ihres AI Vision Sensors. Für optimale Leistung montieren Sie es nach unten zum Feld hin geneigt. Dadurch wird sichergestellt, dass nur Objekte innerhalb des Feldes und keine umliegenden Bereiche erkannt werden. Tipps zur Montage Ihres AI Vision-Sensors finden Sie unter Montieren Ihres AI Vision-Sensors.
Lösung für mögliche Ursache 2
Visuelle Störungen rund um den AI Vision Sensor können zu Erkennungsfehlern führen. Objekte in der Umgebung (wie etwa Plakate oder Kleidung), die der gewünschten Farbsignatur entsprechen, werden vom Sensor möglicherweise fälschlicherweise identifiziert. Weitere Informationen zum Minimieren optischer Störungen bei der Einrichtung Ihres Felds finden Sie unter Einrichten Ihrer Unterrichtsumgebung für die Verwendung des AI Vision Sensors.
Lösung für mögliche Ursache 3
Wenn eine Farbsignatur nicht mit einem ausreichend breiten Farbton- und/oder Sättigungsgrad konfiguriert ist, wird die Farbsignatur eines Objekts nicht richtig erkannt oder es werden Farben erkannt, die zu falschen Objekten gehören. Lesen Sie Konfigurieren von Farbsignaturen mit dem AI Vision Sensor“ in VEXcode EXP oder sehen Sie sich Anpassen einer Farbsignatur auf PD+ an, um weitere Informationen zum Konfigurieren einer Farbsignatur zu erhalten, damit der AI Vision Sensor die gewünschte Farbe genau erkennt.
Lösung für mögliche Ursache 4
Die Lichtverhältnisse können den Farbton und die Sättigung einer Farbe erheblich beeinflussen. Beim Konfigurieren einer Farbsignatur ändern sich die Werte abhängig von der aktuellen Lichtmenge auf dem Objekt.
Wenn sich die Lichtmenge ändert, wird die gleiche Farbsignatur möglicherweise nicht so genau erkannt.
Um dies zu beheben, stellen Sie sicher, dass die Farbsignatur des AI Vision-Sensors dort konfiguriert wird, wo der Sensor im Feld verwendet wird, damit die Farbsignaturerkennung konsistent bleibt.