Neue Funktionen in VEXcode V5 4.0

VEXcode V5 4.0 führt eine Reihe neuer Funktionen ein. Der Schwerpunkt dieses wichtigen Updates liegt auf der Verbesserung der Produktivität und Zugänglichkeit bei der Robotercodierung. Lesen Sie weiter, um zu erfahren, welche neuen Funktionen mit VEXcode V5 4.0 verfügbar sind!

Klicken Sie hier, um das neue Installationsprogramm für VEXcode V5 4.0 herunterzuladen!

Schalterblöcke

Jetzt sind neue Switch-Blöcke verfügbar, die den Übergang von der blockbasierten Codierung zur textbasierten Programmierung nahtlos gestalten.

Der Schalterblock wird in VEXcode V5 angezeigt, wie er aus der Toolbox in den Arbeitsbereich gezogen wird. Der Benutzer wählt den Switch-Block aus und beginnt, einen Python-Befehl einzugeben.

Drag-and-Drop-Schalterblöcke: Alle Schaltblöcke können aus der Toolbox gezogen und direkt eingegeben werden.

Der Schalterblock wird im VEXcode V5 Workspace angezeigt. Ein Benutzer verwendet die Autokorrekturfunktion, um einen vollständigen Python-Befehl in den Block einzugeben. Der Befehl lautet drivetrain.turn_for(LEFT, 90, DEGREES).

Geben Sie Python direkt in Blockprojekte ein: VEXcode ermöglicht Ihnen, Python-Befehle direkt in Ihre Projekte einzubinden und sie nahtlos in andere Blöcke zu integrieren. Um Sie beim Schreiben korrekten Codes zu unterstützen, bietet VEXcode auch eine Autovervollständigungsfunktion für Python-Befehle.

Im VEXcode V5 Workspace wird ein Stapel von Motion-Blöcken angezeigt. Der Benutzer klickt mit der rechten Maustaste auf den Stapel, um dessen Kontextmenü zu öffnen, und wählt dann die Option "Stapel in Switch-Block umwandeln" aus. Der Stapel aus drei Blöcken wird in einen Switch-Block mit drei entsprechenden Python-Zeilen umgewandelt.

Code-Konvertierung: Konvertieren Sie ganze Blockstapel mit einem einzigen Klick in Python.

Diese Funktion ist ideal für Lernende, die von Blöcken auf Text umsteigen möchten. Weitere Informationen zum Codieren mit Switch Blocks finden Sie hier.


Speichern und Laden im webbasierten VEXcode

Das Feld „Projektname“ in der VEXcode V5-Symbolleiste zeigt eine Speichermeldung an, die sich beim Speichern des Projekts aktualisiert. Zuerst erscheint die Meldung „Nicht gespeichert“, dann „Speichern“ und schließlich „Gespeichert“.

Der webbasierte VEXcode speichert Projektänderungen jetzt automatisch, nachdem Ihr Projekt zunächst gespeichert wurde.

Weitere Änderungen am Dateimenü:

  • „Von Ihrem Gerät laden wurde jetzt inÖffnengeändert.
  • „Auf Ihrem Gerät speichern wurde jetzt in„Speichern untergeändert.
  • Sie können jetzt auch manuell mit der Schaltfläche Speichern speichern.

Eine Schritt-für-Schritt-Anleitung zum Laden und Speichern eines VEXcode V5-Projekts in einem Chrome-Browser finden Sie hier.


Aktualisierte AI Vision Sensor-Erkennung

Der AI Vision Sensor kann jetzt AprilTags und AI-Klassifizierungen erkennen.

Das Menü „AI Vision Utility“ in VEXcode V5 zeigt den Live-Feed der Kamera an, der drei AprilTags erfasst. Die AprilTags-Funktion ist aktiviert, die KI-Klassifizierung ist deaktiviert. Die erkannten Tags sind mit ihren jeweiligen IDs, Koordinaten und Abmessungen gekennzeichnet.

AprilTags sind Bilder, die erkannt werden können und eindeutige IDs haben. Sie können ausgedruckt und auf dem Feld zur Nutzung mit Robotern eingesetzt werden. Laden Sie hier ein druckbares AprilTag-PDF herunter.

Menü „AI Vision Utility“ in VEXcode V5. Das Menü zeigt einen Live-Kamera-Feed mit vier erkannten Objekten: zwei blaue Ringe, ein roter Ring und ein bewegliches Ziel, jeweils mit Begrenzungsrahmen, die ihre Farben, Positionen, Abmessungen und Konfidenzwerte anzeigen. Im rechten Bereich befinden sich Optionen zum Aktivieren von AprilTags und KI-Klassifizierung, wobei der Modus für die KI-Klassifizierung auf „Klassenzimmerelemente“ eingestellt ist.

Zu den KI-Klassifizierungsmodellen gehören Classroom Elements, die in Bildungseinrichtungen zum Erkennen von Bällen, Ringen und Würfeln unterschiedlicher Farben eingesetzt werden können, sowie Competition Elements, die die Erkennung von Spielelementen im aktuellen High Stakes-Spiel VEX Robotics Competition (V5RC) 2024–2025 unterstützen.

Klicken Sie hier, um zu erfahren, wie Sie den AI Vision Sensor in Blöcken, Pythonund C++verwenden.


Blöcke laut vorlesen

Alle Blöcke in VEXcode V5 4.0 können jetzt mit einem einfachen Rechtsklick vorgelesen werden.

Diese Funktion ist auf allen Geräten außer Android verfügbar.

Der VEXcode V5 Drive für den Block wird mit geöffnetem Kontextmenü angezeigt. Die Optionen lauten von oben nach unten: Duplizieren, Block deaktivieren, Blöcke löschen, Blockhilfe, Block in Wechselblock umwandeln und Block lesen. Die Option „Block lesen“ ist hervorgehoben.

  • Anpassbare Stimmen: Wählen Sie aus verschiedenen Stimmen und passen Sie Geschwindigkeit und Tonhöhe im neuen Werkzeugmenü an.
  • Kontextmenü-Integration: Klicken Sie mit der rechten Maustaste auf einen beliebigen Block, um ihn vorgelesen zu bekommen.

Hier finden Sie schrittweise Anleitungen zur Verwendung der Lesefunktion in VEXcode.


Menü „Extras“

VEXcode V5 4.0 hat das Menü „Tools“ aus dem Menü „Datei“ in die Symbolleiste verschoben und ist jetzt vollgepackt mit Funktionen für Produktivität und Zugänglichkeit.

VEXcode V5 Toolbar mit geöffnetem Dropdown-Menü „Tools“. Es werden fünf Optionen angezeigt: Design, Tastenkombinationen, Spracheinstellungen, VEXcode-Sounds verwalten und API-Dokumentation.

Tastaturkürzel

Zum Starten, Stoppen und Öffnen der Hilfedokumentation stehen neue Tastaturkürzel zur Verfügung.

Mac Windows
VEXcode V5 Mac Toolbar mit geöffnetem Dropdown-Menü „Tools“ und ausgewählter Option „Tastenkombinationen“. Die verfügbaren Tastenkombinationen werden in einem zweiten Dropdown-Menü auf der rechten Seite angezeigt. Dort stehen drei Optionen zur Verfügung: Start, Stopp und Hilfe öffnen. Jeder Option ist eine entsprechende Tastenkombination zugeordnet. Die Start-Taste ist die Befehlstaste plus die Eingabetaste, die Stopp-Taste ist die Befehlstaste plus die E-Taste und die Hilfe-Taste ist die Befehlstaste plus die H-Taste. VEXcode V5 Windows Toolbar mit geöffnetem Dropdown-Menü „Tools“ und ausgewählter Option „Tastenkombinationen“. Die verfügbaren Tastenkombinationen werden in einem zweiten Dropdown-Menü auf der rechten Seite angezeigt. Dort stehen drei Optionen zur Verfügung: Start, Stopp und Hilfe öffnen. Jeder Option ist eine entsprechende Tastenkombination zugeordnet. Die Start-Taste ist die Strg-Taste plus die Eingabetaste, die Stopp-Taste ist die Strg-Taste plus die E-Taste und die Hilfe-Taste ist die Strg-Taste plus die H-Taste.

Design mit hohem Kontrast

Kontrastreiche Designs erhöhen die Unterscheidung zwischen Text und Hintergrund und erleichtern so das Lesen von Inhalten für Benutzer mit Sehschwäche, Farbenblindheit oder anderen Sehbehinderungen.

Standard Hoher Kontrast
VEXcode V5-Blockprojekt mit Blöcken aus verschiedenen Kategorien zur Veranschaulichung des Standardfarbschemas. VEXcode V5-Blockprojekt mit Blöcken aus verschiedenen Kategorien zur Veranschaulichung des kontrastreichen Farbschemas.

Spracheinstellungen

Wenn Sie mit der neuen Funktion „Blöcke lesen“ arbeiten, können Sie in diesem Menü die verwendete Stimme, die Sprechgeschwindigkeit und die Tonhöhe ändern.

Das Fenster „VEXcode V5 Speech Settings“ verfügt über ein Dropdown-Menü zur Auswahl der Stimme, zwei Schieberegler zum Ändern der Tonhöhe und Geschwindigkeit sowie eine Schaltfläche „Test Voice“, um die aktuellen Spracheinstellungen anzuhören.

API-Dokumentation

Greifen Sie auf die umfassende API-Dokumentation zu, mit der Sie das volle Potenzial Ihres VEX V5-Roboters einfacher als je zuvor erkunden und nutzen können.

VEXcode V5 API-Dokumentationsseite für den Python-Befehl drive. Die API-Seiten enthalten Erläuterungen, Funktionen und Beispielprojekte für jeden Block- und Textbefehl.

Klicken Sie hier, um auf die offizielle VEX-API-Referenzseite zuzugreifen.


Webbasierte Downloads für Wireless-Projekte

Der webbasierte VEXcode V5 kann jetzt über einen V5-Controller eine drahtlose Verbindung zu einem V5 Brain herstellen.

VEXcode V5 Toolbar mit einem grün hervorgehobenen Controller-Symbol.

Um zu erfahren, wie Sie ein Projekt drahtlos auf Ihr V5 Brain herunterladen, klicken Sie hier.

For more information, help, and tips, check out the many resources at VEX Professional Development Plus

Last Updated: