Přehled VEXcode Pro V5

The VEX Visual Studio Code Extension has replaced VEXcode Pro V5, which is now end-of-life.

VEXcode Blocks and VEXcode Text remain actively developed and supported for all VEX platforms.

VEXcode Pro V5 poskytuje uživatelům autentický zážitek z programování, protože se stávají zkušenějšími programátory. Ať už přecházíte z blokového jazyka nebo jste zkušený textový programátor, následující článek se bude zabývat hlavními funkcemi uživatelského rozhraní (UI) VEXcode Pro V5.

Rozhraní VEXcode Pro V5 zobrazující označené prvky uživatelského rozhraní včetně nabídky Soubor, ikon panelu nástrojů, editoru kódu, stromu souborů, výstupního panelu a minimapy.

Okna

Rozhraní VEXcode Pro V5 pro Windows zobrazující otevřenou nabídku Soubor s možnostmi Nový, Otevřít, Otevřít příklady, Importovat, Exportovat a Uložit.

Mac

Rozhraní VEXcode Pro V5 pro Mac zobrazující otevřenou nabídku Soubor s možnostmi Nový, Otevřít, Otevřít příklady, Importovat, Exportovat a Uložit.

Výběrem Soubor se otevře Nabídka Soubor s následujícími možnostmi:

Okna

Nabídka úprav ve VEXcode Pro V5 pro Windows zobrazující možnosti včetně Zpět, Znovu, Vyjmout, Kopírovat, Vložit, Najít a Nahradit.

Mac

Nabídka úprav pro VEXcode Pro V5 pro Mac zobrazující možnosti včetně Zpět, Znovu, Vyjmout, Kopírovat, Vložit, Najít a Nahradit.

Výběrem Úpravy se otevře nabídka Úpravy možností úprav

Okna

Nabídka Nástroje systému Windows ve VEXcode Pro V5 zobrazující možnosti včetně Palety příkazů, Formátování dokumentu a ovládacích prvků pro komentáře.

Mac

Nabídka nástrojů pro Mac ve VEXcode Pro V5 zobrazující možnosti včetně palety příkazů, formátování dokumentu a ovládacích prvků pro komentáře.

Výběrem Nástroje se otevře nabídka Nástroje z následujících možností

  • Sbalit strom souborů minimalizuje panel Strom souborů a zvětší tak oblast úprav.

Rozhraní VEXcode Pro V5 zobrazující selektor slotů projektu se sloty 1 až 8 dostupnými ke stažení.

Project Slot umožňuje uživatelům vybrat si jeden z osmi slotů na Brain, kam bude projekt stažen.

Okno s podrobnostmi projektu VEXcode Pro V5 zobrazující název projektu, popis a expertní možnosti včetně automatického dokončování a konfigurace robota.

Název projektu umožňuje uživatelům přiřadit projektu název pro snadnou orientaci.

  • Kliknutím na Název projektu se otevře okno Podrobnosti projektu, kde můžete kliknutím povolit možnosti expertů. 
  • Indikátor ovladače bude šedý, pokud není připojen žádný ovladač, oranžový, pokud je připojen, ale neexistuje rádiové spojení s mozkem, a zelený, pokud je připojen k mozku. 
  • Informace o mozku ukazuje, zda je robotický mozek V5 připojen (zelený) k uživatelskému rozhraní, není připojen (šedý) nebo je třeba jej aktualizovat (zelený mozek s oranžovým výstražným trojúhelníkem).

Panel nástrojů VEXcode Pro V5 zobrazující umístění tlačítek Stáhnout projekt a Sestavit, když není připojen žádný mozek.

Stáhnout projekt je tlačítko, které se objeví, když je mozek připojen, aby si uživatelé mohli stáhnout projekt do mozku.

Poznámka: Když není mozek připojen, tlačítko Stáhnout je nahrazeno tlačítkemBuildzobrazeným zde:

  • Run umožňuje uživateli spustit projekt prostřednictvím uživatelského rozhraní poté, co byl již stažen do robota.
  • Stop umožňuje uživateli zastavit projekt prostřednictvím uživatelského rozhraní.
  • Robot Config zobrazuje konfiguraci robota, takže uživatelé mohou přidávat, odebírat a upravovat zařízení obsažená v sestavení robota.
  • Nápověda poskytuje uživateli nápovědu k jednotlivým příkazům a/nebo poskytuje přehled příkazů.
  • Zpětná vazba umožňuje uživatelům přímo hodnotit své zkušenosti s uživatelským rozhraním a zprávou VEX.
  • Split Editor se používá k rozdělení obrazovky úprav tak, že uživatelské rozhraní má dvě karty pro prohlížení dvou různých souborů v rámci projektu nebo pro prohlížení různých částí stejného souboru.
  • Mini mapa ukazuje uživatelům, která část zdrojového souboru je aktuálně zobrazena v okně editoru, a umožňuje uživateli rychle procházet celým souborem přetažením zvýrazněné části.
  • Strom souborů poskytuje uživatelům seznam složek a jejich souborů, které se používají v rámci projektu, takže uživatelé mohou vybrat vstupní soubor, který chtějí upravit.
  • Sbalit záložky výstupu minimalizuje záložky výstupu, aby se zvětšila oblast úprav.
  • Výstup uvádí informace o ukládání, kompilaci a generovaných chybách.
  • Problémy uvádí chyby, varování a informace o problémech. 
  • Terminál zobrazuje text vytištěný z uživatelského projektu běžícího na mozku, když je mozek připojen přes přímé USB nebo ovladač. Umožňuje také uživateli po připojení odeslat text do projektu běžícího na mozku.
  • Clear umožňuje uživateli odstranit zprávy z obrazovek Výstup a Terminál.  

Související články:

For more information, help, and tips, check out the many resources at VEX Professional Development Plus

Last Updated: