Carregando e salvando um projeto VEXcode VR no Windows

Um projeto pode ser carregado e salvo no VEXcode VR de algumas maneiras.

Nota: Devido a limitações do navegador, diferentes navegadores da web exibirão opções variadas para salvar e carregar. Certifique-se de seguir as instruções específicas do seu navegador. Não vê seu navegador listado? Certifique-se de que o seu navegador suporta VEXcode VR aqui.


Verifique a compatibilidade do salvamento automático

A compatibilidade do navegador para salvamento automático varia. Para determinar se o seu navegador suporta esse recurso, siga estas etapas:

Botão "Project" na barra de ferramentas do VEXcode VR para abrir o menu de carregar e guardar.

Selecione o nome do projeto.

Caixa de diálogo de guardar que mostra o suporte para guardar automaticamente o navegador para o projeto VEXcode VR.

Se o navegador da web suportar salvamento automático, ele dirá Navegador com capacidade de salvamento automático.

Se o salvamento automático estiver disponível, o VEXcode salvará automaticamente todas as alterações assim que você abrir ou salvar inicialmente um projeto no seu computador.

Diálogo de guardar do Windows com a opção Guardar automático indisponível selecionada para um projeto VEXcode VR

Se o navegador da Web não suportar o salvamento automático, ele dirá Salvamento automático indisponível.

Se o salvamento automático não estiver disponível, você deverá salvar manualmente seu projeto após cada alteração para evitar perda de dados.

Consulte a seção "Salvar usando o menu Arquivo" deste artigo para saber como salvar seu projeto.


Abrir um projeto existente

Google Chrome ou Microsoft Edge

Menu Ficheiro apresentando as opções Abrir Projecto e Guardar no Seu Dispositivo no VEXcode VR para Windows

Carregue um projeto existente selecionando Abrirno menu Arquivo.

Abra a caixa de diálogo com o ficheiro Drive Forward.vrblocks selecionado na pasta Downloads.

Use a interface do Windows para navegar e abrir seu projeto VEXcode VR existente. 

Raposa de fogo

Opção do menu Ficheiro para carregar um projeto do seu dispositivo (Ctrl+O)

Carregue um projeto existente selecionando Carregar do seu dispositivo no menu Arquivo.

Abra a caixa de diálogo com o ficheiro Drive Forward.vrblocks selecionado na pasta Downloads.

Use a interface do Windows para navegar e abrir seu projeto VEXcode VR existente.


Abra um projeto de exemplo

Menu Ficheiro exibindo as opções "Carregar do seu dispositivo" e "Guardar no seu dispositivo" no VEXcode VR

Abra um projeto de exemplo selecionando Abrir Exemplos no menu Arquivo. Este texto é o mesmo em todos os navegadores.

Para saber mais sobre como usar Projetos de Exemplo no VEXcode VR, veja este artigo.


Renomear um projeto

Google Chrome ou Microsoft Edge

Botão "Project" na barra de ferramentas do VEXcode VR para abrir o menu de carregar e guardar.

Para renomear um projeto, selecione a janela Nome do Projeto.

Diálogo "Guardar projeto como" com o campo de nome do projeto selecionado no Windows.

O texto dentro da janela Nome do Projeto será destacado. Digite o novo nome do seu projeto.

Diálogo "Guardar como" do Windows exibindo o campo de nome do projeto VEXcode VR.

Depois que o nome do projeto for alterado, o botão Salvar será habilitado.

Selecione Salvar.

A caixa de diálogo "Guardar como" apresenta o nome do projeto Robot Drive.vrblocks antes de guardar.

Navegue até onde você deseja salvar seu projeto e selecione Salvar.

Menu Ficheiro exibindo as opções "Carregar do seu dispositivo" e "Guardar no seu dispositivo" no VEXcode VR

O indicador de salvamento automático à direita do nome do projeto agora mudará para Salvo.

A caixa de diálogo "Guardar como" mostra onde introduzir o nome do projeto e guardar o projeto VEXcode VR.

Agora, quando você selecionar a janela Nome do Projeto, o botãoSalvar mudará para um botãoSalvar Como.

Raposa de fogo

O botão Project abre o menu de projetos VEXcode VR.

Para renomear um projeto, selecione a janela Nome do Projeto.

A caixa de diálogo "Guardar" apresenta o campo "Nome do projeto" ativo, mas a opção "Guardar" está desativada até que seja introduzido um nome.

O texto dentro da janela Nome do Projeto será destacado. Digite o novo nome do seu projeto.

Diálogo de guardar exibindo o nome do projeto VEXcode VR antes de guardar o ficheiro.

Depois que o nome do projeto for alterado, o botão Salvar será habilitado. SelecioneSalvar para aplicar o novo nome ao seu projeto.

Botão "Guardar no seu dispositivo" na barra de ferramentas do VEXcode VR

O nome do projeto mudará na parte superior do projeto.

Importante: O Firefox não suporta salvamento automático. As alterações no nome do projeto não serão salvas até que você salve o projeto manualmente no seu dispositivo.


Salvar usando o menu Arquivo

Google Chrome ou Microsoft Edge

Menu Ficheiro exibindo as opções "Carregar do seu dispositivo" e "Guardar no seu dispositivo" no VEXcode VR

Abra o menu Arquivo e selecione Salvar ouSalvar como.

Menu Ficheiro mostrando o comando Guardar e o atalho Ctrl+S no VEXcode VR

Uma caixa de diálogo será exibida. Navegue até onde você deseja salvar seu projeto VEXcode e selecioneSalvar.

O ficheiro Project.vrblocks foi selecionado na pasta Downloads para importação no VEXcode VR.

Seu arquivo será salvo no local escolhido.

Raposa de fogo

Menu Ficheiro mostrando Guardar no seu dispositivo com o atalho Ctrl+S

Abra o menu Arquivo e selecione Salvar no seu dispositivo.

Download completo do projeto VEXcode .vrblocks, com opção para exibir o ficheiro na sua pasta.

A notificação de salvamento aparecerá na parte superior do navegador.

O ficheiro Project.vrblocks foi selecionado na pasta Downloads para importação no VEXcode VR.

Seu arquivo será salvo no local escolhido.

Importante: O Firefox não suporta salvamento automático. As alterações do projeto não serão salvas até que você salve o projeto manualmente no seu dispositivo.


Problema comum ao carregar/salvar

O Windows apresenta uma mensagem a informar que o ficheiro não tem uma aplicação associada e direcionando o utilizador para as definições de Aplicações Padrão.

Um problema comum ao usar arquivos de projeto do VEXcode é tentar selecionar o arquivo de projeto a ser aberto diretamente pelo sistema operacional.

Uma caixa de diálogo do Windows pergunta qual a aplicação que deve abrir um ficheiro de projeto .vrblocks.

Se você tentar abrir um arquivo de projeto VEXcode clicando duas vezes nele, ele mostrará esta mensagem de erro.

Para abrir esses arquivos corretamente, todos os arquivos VEXcode VR devem ser abertos no VEXcode VR.

For more information, help, and tips, check out the many resources at VEX Professional Development Plus

Last Updated: