Carregando e salvando um projeto VEXcode VR no macOS

Um projeto pode ser carregado e salvo no VEXcode VR de algumas maneiras.

Nota: Devido a limitações do navegador, diferentes navegadores da web exibirão opções variadas para salvar e carregar. Certifique-se de seguir as instruções específicas do seu navegador. Não vê seu navegador listado? Certifique-se de que o seu navegador suporta VEXcode VR aqui.


Verifique a compatibilidade do salvamento automático

A compatibilidade do navegador para salvamento automático varia. Para determinar se o seu navegador suporta esse recurso, siga estas etapas:

O campo Nome do projeto apresenta “Projeto VEXcode” com o estado “Não guardado”.

Selecione o nome do projeto.

O browser solicita permissão para que o VEXcode VR guarde ficheiros neste Mac.

Se o navegador da web suportar salvamento automático, ele dirá Navegador com capacidade de salvamento automático.

Se o salvamento automático estiver disponível, o VEXcode salvará automaticamente todas as alterações assim que você abrir ou salvar inicialmente um projeto no seu computador.

A caixa de diálogo de guardar indica que o guardar automático não está disponível para o projeto VEXcode VR no macOS.

Se o navegador da Web não suportar o salvamento automático, ele dirá Salvamento automático indisponível.

Se o salvamento automático não estiver disponível, você deverá salvar manualmente seu projeto após cada alteração para evitar perda de dados.

Consulte a seção "Salvar usando o menu Arquivo" deste artigo para saber como salvar seu projeto.


Abrir um projeto existente

Google Chrome ou Microsoft Edge

Menu Ficheiro exibindo as opções Abrir Projecto e Guardar no macOS

Abra um projeto existente selecionando Abrir no menu Arquivo.

O ficheiro VEXcode Project.vrblocks foi selecionado na pasta Downloads para ser aberto no VEXcode VR.

Use a interface do macOS para navegar e abrir seu projeto existente. VEXcode VR só permitirá que você abra arquivos com extensão .vrblocks.

Firefox ou Safari

Menu Ficheiro com opções para guardar ou carregar um projeto VEXcode VR no seu dispositivo.

Abra um projeto existente selecionando Carregar do seu dispositivo no menu Arquivo.

O ficheiro VEXcode Project.vrblocks foi selecionado na pasta Downloads para ser aberto no VEXcode VR.

Use a interface do macOS para navegar e abrir seu projeto existente. O VEXcode VR só permitirá que você abra arquivos com extensão .vrblocks.


Abra um projeto de exemplo

Opções de menu Carregar e Guardar para abrir ou guardar um projeto VEXcode VR no macOS

Abra um projeto de exemplo selecionando Abrir Exemplos no menu Arquivo.

Saiba mais sobre como usar projetos de exemplo no VEXcode VR neste artigo.


Renomear um projeto

Google Chrome ou Microsoft Edge

O campo Nome do projeto apresenta “Projeto VEXcode” com o estado “Não guardado”.

Para renomear um projeto, selecione a janela Nome do Projeto.

Abra a caixa de diálogo Guardar com o campo de nome do projeto selecionado para renomear o projeto VEXcode VR antes de guardar.

O texto dentro da janela Nome do Projeto será destacado. Digite o novo nome do seu projeto.

A caixa de diálogo Guardar mostra o nome do projeto Robot Drive pronto para ser guardado.

Depois que o nome do projeto for alterado, o botão Salvar será habilitado.

Selecione Salvar para aplicar o novo nome ao seu projeto.

Diálogo de guardar com o ficheiro Robot Drive.vrblocks selecionado para guardar o projeto VEXcode VR.

Selecione onde deseja salvar seu projeto e selecione Salvar.

Menu Ficheiro mostrando as opções Abrir Projecto e Guardar no seu dispositivo no macOS

O indicador de salvamento automático à direita do nome do projeto agora mudará para Salvo.

Caixa de diálogo "Guardar como" para nomear e guardar um projeto VEXcode VR no macOS.

Agora, quando você selecionar a janela Nome do Projeto, o botãoSalvar mudará para um botãoSalvar Como.

Raposa de fogo

Campo de nome do projeto no VEXcode VR, mostrando onde inserir ou visualizar o título do projeto.

Para renomear um projeto, selecione a janela Nome do Projeto.

A caixa de diálogo Guardar, que apresenta o campo do nome do projeto, deve ser preenchida antes de o botão Guardar ficar disponível.

O texto dentro da janela Nome do Projeto será destacado. Digite o novo nome do seu projeto.

Diálogo de guardar do macOS mostrando o campo de nome do projeto VEXcode VR e as opções de local de guardar.

Depois que o nome do projeto for alterado, o botão Salvar será habilitado. SelecioneSalvar para aplicar o novo nome ao seu projeto.

O campo Nome do projeto apresenta Acionamento do Robô sem um indicador de projeto guardado.

O nome do projeto mudará na parte superior do projeto.

Importante: O Firefox não suporta salvamento automático. As alterações no nome do projeto não serão salvas até que você salve o projeto manualmente no seu dispositivo.

Safári

Campo de nome do projeto no VEXcode VR, mostrando onde inserir ou visualizar o título do projeto.

Para renomear um projeto, selecione a janela Nome do Projeto.

A caixa de diálogo Guardar, que apresenta o campo do nome do projeto, deve ser preenchida antes de o botão Guardar ficar disponível.

O texto dentro da janela Nome do Projeto será destacado. Digite o novo nome do seu projeto.

Diálogo de guardar do macOS mostrando o campo de nome do projeto VEXcode VR e as opções de local de guardar.

Depois que o texto dentro do campo de texto for alterado, o botãoSalvar será habilitado. SelecioneSalvar para aplicar o novo nome ao seu projeto.

O campo Nome do projeto apresenta Acionamento do Robô sem um indicador de projeto guardado.

O nome do projeto mudará na parte superior do projeto.

Importante: O Safari não suporta salvamento automático. As alterações no nome do projeto não serão salvas até que você salve o projeto manualmente no seu dispositivo.


Salvar usando o menu Arquivo

Google Chrome ou Microsoft Edge

Opção Guardar no menu Ficheiro do VEXcode VR no macOS

Abra o menu Arquivo e selecione Salvar ouSalvar como. 

Caixa de diálogo de guardar que mostra o projeto denominado VEXcode Project.vrblocks a ser guardado na pasta Downloads.

Selecione onde deseja salvar seu projeto e selecione Salvar.

Ficheiro de projeto VEXcode VR guardado na pasta Downloads

Seu arquivo será salvo no local escolhido.

Raposa de fogo

Menu Ficheiro mostrando as opções para abrir exemplos, abrir um projeto do seu dispositivo, guardar no seu dispositivo e guardar como no VEXcode VR.

Abra o menu Arquivo e selecione Salvar no seu dispositivo.

A notificação do navegador confirma que o ficheiro de projeto VEXcode foi descarregado com sucesso.

A notificação de salvamento aparecerá na parte superior do navegador.

Ficheiro de projeto VEXcode VR guardado na pasta Downloads

Seu arquivo será salvo no local de download padrão.

Importante: O Firefox não suporta salvamento automático. Quaisquer alterações no projeto não serão salvas até que você salve o projeto manualmente no seu dispositivo.

Safári

Menu Ficheiro mostrando as opções para abrir exemplos, abrir um projeto do seu dispositivo, guardar no seu dispositivo e guardar como no VEXcode VR.

Abra o menu Arquivo e selecione Salvar no seu dispositivo.

Botão de download na barra de ferramentas VEXcode VR no macOS

A notificação de download aparecerá na parte superior do navegador.

Ficheiro de projeto VEXcode VR guardado na pasta Downloads

Seu arquivo será salvo no local de download padrão.

Importante: O Safari não suporta salvamento automático. Quaisquer alterações no projeto não serão salvas até que você salve o projeto manualmente no seu dispositivo.


Problema comum ao carregar/salvar

Mensagem macOS a informar que o ficheiro Drive.vrblocks não pode ser aberto porque nenhuma aplicação está configurada para o abrir.

Um problema comum ao usar arquivos de projeto VEXcode é tentar selecionar o projeto a ser aberto diretamente pelo sistema operacional.

Para abrir esses arquivos corretamente, todos os arquivos VEXcode VR devem ser abertos no VEXcode VR.

For more information, help, and tips, check out the many resources at VEX Professional Development Plus

Last Updated: