Usando a ajuda no VEXcode Pro V5

The VEX Visual Studio Code Extension has replaced VEXcode Pro V5, which is now end-of-life.

VEXcode Blocks and VEXcode Text remain actively developed and supported for all VEX platforms.

A ajuda dentro do VEXcode Pro V5 pode fornecer aos usuários uma explicação de como usar um comando em seus projetos.

Abrindo a janela de ajuda

Barra de ferramentas do VEXcode Pro V5 com o ícone de Ajuda destacado no canto superior direito.

Clique no ícone Ajuda para abrir a janela Ajuda. O ícone de Ajuda é o ícone de ponto de interrogação no canto superior direito do VEXcode Pro V5.

O painel de Ajuda do VEXcode Pro V5 é aberto, apresentando o separador Ajuda de Comandos vazio, com instruções para clicar com o botão direito do rato num método para visualizar as suas informações de Ajuda.

Uma janela de Ajuda vazia aparecerá por padrão.

Como obter ajuda para um comando

Painel de ajuda do VEXcode Pro V5 exibindo a documentação do comando Drivetrain.drive() com a descrição e exemplos de utilização.

Para ver a ajuda, clique com o botão direito no comando. Por exemplo: Drivetrain.drive(forward);

Neste exemplo, Drivetrain é o nome do dispositivo, drive é o nome do comando e as informações entre parênteses são os parâmetros.

Clique com o botão direito no nome de um comando em seu projeto e selecione “Command Help” para saber mais sobre como usar o comando. As informações sobre esse comando aparecerão na janela Ajuda.

Painel de ajuda do VEXcode Pro V5 a apresentar a lista de opções de comando para diferentes dispositivos, como Brain Screen, Bumper, Controller e Limit.

Se vários dispositivos compartilharem o mesmo nome de comando, você receberá uma solicitação para selecionar o dispositivo com o qual deseja ajuda. Você pode selecionar um dispositivo clicando no nome do comando na lista fornecida.

VEXcode Pro V5 com o menu Ferramentas destacado no canto superior esquerdo.

Se nenhuma ajuda de comando for encontrada, dê uma olhada em nossa guia “Ajuda Avançada”. Você pode acessar a “Ajuda Avançada” clicando em “Ferramentas” no menu superior.

O menu Ferramentas do VEXcode Pro V5 é aberto com a opção Abrir Ajuda Avançada (no browser) selecionada.

Em seguida, selecione “Abrir Ajuda Avançada (No Navegador)”.

Aceder à Referência de Comandos

Painel de ajuda do VEXcode Pro V5 mostrando o separador Referência de Comandos com categorias expansíveis, incluindo Transmissão, Aparência, Eventos, Controlo e Sensores.

A Referência de Comandos contém uma lista de comandos disponíveis para cada dispositivo configurado dentro do seu projeto.

Fechar a janela de ajuda

Barra de ferramentas do VEXcode Pro V5 com o ícone de Ajuda destacado para indicar que é possível clicar nele para fechar o painel de Ajuda.

Clique no botão Ajuda na barra de ferramentas novamente para fechar a janela Ajuda.

For more information, help, and tips, check out the many resources at VEX Professional Development Plus

Last Updated: