Lecture de sons importés personnalisés dans un projet VEXcode V5

La lecture de sons importés personnalisés est une fonction unique du logiciel VEXcode V5. Cet article vous expliquera où et comment importer des sons dans VEXcode V5, la configuration requise pour garantir que les sons sont lus correctement et une explication du fonctionnement de la commande play VEXcode sound.

Blocs VEXcode V5

Projet de blocs VEXcode V5 qui lit : Au démarrage, jouez le son VEXcode arrow, avancez de 200 mm, puis jouez le son VEXcode game over.

VEXcode V5 Python

# Importation de bibliothèques
from vex import *

# Début du code du projet
play_vexcode_sound("arrow")
drivetrain.drive_for(FORWARD, 200, MM)
play_vexcode_sound("game over")

VEXcode V5 C++

// Inclure la bibliothèque V5
#include "vex.h"

// Permet une utilisation plus simple de la bibliothèque VEX
using namespace vex;

int main() {
  playVexcodeSound("arrow");
  Drivetrain.driveFor(forward, 200, mm);
  playVexcodeSound("game over");
}

Sélectionnez l'image ci-dessus pour l'agrandir.

Accès à la commande Play VEXcode Sound

Par défaut, la commande play VEXcode sound n'apparaît pas dans la boîte à outils sur le côté gauche de l'écran. Les étapes suivantes expliquent comment activer la commande.

Barre d'outils VEXcode V5 avec le menu Fichier ouvert et le sous-menu Outils ouvert. L'option « Gérer les sons VEXcode » se trouve dans le sous-menu Outils et elle est mise en surbrillance.

Accédez au menu Fichier. Sélectionnez « Outils » et « Gérer les sons VEXcode ».

Note: cette image montre des blocs dans la boîte à outils mais le processus est le même pour les projets C++ et Python.

VEXcode V5 : Menu « Gérer les sons VEXcode » contenant la liste des sons importés et l’emplacement de leurs fichiers. Le menu comporte également une case à cocher pour activer les sons VEXcode, et deux boutons en dessous qui indiquent Annuler et Enregistrer les sons.

Le menu Gérer les sons VEXcode apparaîtra alors.

Dans le menu VEXcode V5, gérez les sons VEXcode en cochant la case « Activer les sons VEXcode » (en surbrillance).

Cochez la case pour activer la commande play VEXcode sound.

Fonctionnalités du menu Gérer les sons VEXcode

Le menu Gérer les sons VEXcode est utilisé pour ajouter des sons, modifier les noms des sons et supprimer des sons.

Ajouter un son

VEXcode V5 Gérer le menu Sons VEXcode avec la prochaine ligne vide de la liste des sons mise en surbrillance. La nouvelle ligne comporte un espace pour le nom du son et un autre espace pour son URL de fichier.

Trouvez une ligne ouverte.

VEXcode V5 Gérer le menu des sons VEXcode en sélectionnant la ligne vide suivante dans la liste des sons et en saisissant le nom à l'aide de la flèche.

Entrez le nom du son dans la case « Nom » associée.

Lorsque vous saisissez un nouveau nom, une ligne vide apparaît sous la ligne actuelle.

VEXcode V5 Gérer le menu Sons VEXcode avec la prochaine ligne vide de la liste des sons mise en surbrillance. Le nom a été défini sur arrow et l'URL du nouveau fichier audio a été saisie.

Collez l'URL du fichier son associé dans la même ligne que le nouveau nom.

VEXcode V5 Gérer le menu Sons de VEXcode avec le bouton Enregistrer les sons mis en surbrillance.

Une fois terminé, sélectionnez « Enregistrer les sons ».

VEXcode V5 Gérer le menu VEXcode Sounds avec le bouton Annuler mis en surbrillance.

Pour modifier le menu Gérer les sons VEXcode, sélectionnez « Annuler ».

Enregistrez les modifications avant de cliquer sur « Annuler » pour éviter de perdre les modifications.

Supprimer un son

VEXcode V5 : Gérez le menu des sons VEXcode avec l’icône de la corbeille à côté du nouveau son de flèche mis en évidence. Chaque son personnalisé est accompagné d'une icône de poubelle.

Cliquez sur l'icône de la corbeille pour supprimer le son lié à cette ligne.

VEXcode V5 : Gérez le menu VEXcode Sounds avec les boutons Enregistrer les sons et Annuler mis en évidence.

Sélectionnez « Enregistrer les sons » pour enregistrer les modifications ou « Annuler » pour quitter le menu.

Note: au moins un son doit toujours être répertorié dans le tableau. L'icône de la poubelle sera grisée lorsqu'il ne reste qu'un seul son, pour garantir qu'il reste un son.

Modifier un son

Menu VEXcode Sounds de VEXcode V5 avec la nouvelle flèche sonore mise en évidence.

Vous pouvez modifier le nom d'un son ou l'URL d'un fichier en le sélectionnant.

VEXcode V5 : Gérez le menu VEXcode Sounds avec les boutons Enregistrer les sons et Annuler mis en évidence.

Sélectionnez « Enregistrer les sons » pour enregistrer les modifications ou « Annuler » pour quitter le menu.

Connexion au port utilisateur/console

Pour lire des sons personnalisés dans VEXcode V5 basé sur le Web, une connexion au port série Web de l'utilisateur/de la console est nécessaire. Ce deuxième port est nécessaire car le premier port série relie le V5 Brain à l'appareil pour les téléchargements de projets à partir d'un navigateur.

Barre d'outils VEXcode V5 avec l'icône verte en forme de cerveau sélectionnée entre les icônes Contrôleur et Téléchargement. Le menu déroulant « Cerveau » comporte un bouton mis en évidence en dessous qui indique « Connecter le port série utilisateur/console ».

Pour connaître les étapes à suivre pour connecter le V5 Brain au port utilisateur/console, cet article.

Le V5 Brain se connecte à un ordinateur portable à l'aide d'un câble USB.

Pour jouer des sons personnalisés, le V5 Brain DOIT rester connecté à l'appareil via un câble USB tout en utilisant le port série Web utilisateur/console.

Utilisation de la commande Lire le son VEXcode

Faites glisser et attachez ou tapez la commande play VEXcode sound à votre projet. Pour plus d'informations sur le fonctionnement du bloc, consultez l'aide.

Blocs VEXcode V5

VEXcode V5 bloque le projet qui lit : Au démarrage, jouez le son VEXcode de fin de partie.

VEXcode V5 Python

# Importation de bibliothèques
from vex import *

# Début du code du projet
play_vexcode_sound("game over")

VEXcode V5 C++

// Inclure la bibliothèque V5
#include "vex.h"

// Permet une utilisation plus facile de la bibliothèque VEX
using namespace vex;

int main() {
  playVexcodeSound("game over");
}

Sélectionnez l'image ci-dessus pour l'agrandir.

Icône de volume indiquant que le volume et les haut-parleurs de l'ordinateur portable sont utilisés lors de la lecture de sons.

Étant donné que les sons sont diffusés via l'appareil connecté, assurez-vous que le volume est élevé lors de la lecture des sons.

Le V5 Brain se connecte à un ordinateur portable à l'aide d'un câble USB.

Assurez-vous que le V5 Brain reste connecté à l'appareil via un câble USB pendant que le projet est téléchargé et en cours d'exécution.

Remarque : les sons personnalisés sont stockés dans le projet VEXcode V5 et fonctionneront tant que le projet spécifique est chargé. Si VEXcode V5 est fermé ou qu'un nouveau projet est chargé, les sons ne fonctionneront pas. Cependant, lors du rechargement du fichier de projet d'origine, la lecture des sons personnalisés reprendra comme prévu.

For more information, help, and tips, check out the many resources at VEX Professional Development Plus

Last Updated: