VEXcode V5 Text provides users with an authentic programming experience as they become more experienced programmers. Whether you are transitioning from a block-based language or are an experienced text-based programmer, the following article will cover the main functionality of the VEXcode V5 Text User Interface (UI).

VEXcode_V5_Text_UI-New_v5.jpg

 

  • Selecting File opens the File Menu with the following options:

Windows:                                              Mac:

File_Menu.png .      File_Menu_Mac.png

 

  • Selecting Edit opens the Edit Menu of editing options: 

Windows:                                               Mac:

Edit_Menu.png .     Edit_Menu_Mac.png

  • Selecting Tools opens the Tools Menu of the following options: 

    Windows:                                            Mac:

 Tools_Menu.png     Tools_Menu_Max.png 

  • Collapse File Tree will minimize the File Tree Panel to enlarge the editing area.
  • Project Slot allows users to select one of the eight slots on the Brain to where the project will be downloaded. 

Slots.png

  • Project Name allows users to assign the project a name for easy reference.
    • Clicking Project Name will open Project Details where you can click to enable expert options. 

EnableExpert.png

  • Controller Indicator will be gray if no controller is connected, orange if connected but there is no radio link to the brain, and green when connected to the brain. 
  • Brain Information shows whether the V5 Robot Brain is connected (green) to the UI, not connected (gray), or needs to be updated (green brain with orange warning triangle).
  • Download Project is the button that appears when the brain is connected so that users can download the project to the brain.
    • Note: When the brain is not connected, the Download button is replaced by the Build button shown here:

CompileCropped.png

  • Run allows the user to start the project through the UI after it’s already been downloaded to the robot.
  • Stop allows the user to stop the project through the UI.
  • Robot Config displays the configuration of the robot so that users can add, remove, and modify the devices included in the robot’s build.
  • Help provides the user with individual Command Help and/or provides the Command Reference.
  • Feedback lets users rate their experiences with the UI and message VEX directly.
  • Split Editor is used to split the editing screen so that the UI has two tabs to look at two different files within the project, or to look at different parts of the same file.
  • Mini Map shows users which portion of the source file is currently displayed in the editor window and allows user to quickly scroll through the whole file by dragging the highlighted section.
  • File Tree provides users with a list of folders and their files that are used within the project so that users can select the input file they want to edit.
  • Collapse Output Tabs will minimize the Output Tabs to enlarge the editing area.
  • Output lists information about saving, compiling, and generated errors.
  • Problems lists errors, warnings, and information about problems. 
  • Terminal displays text printed from a user project running on the brain when the brain is connected via direct USB or the controller. It also allows the user to send text to the project running on the brain when connected.
  • Clear lets the user delete messages from the Output and Terminal displays.  

 

Related articles: